diff options
author | Tim Orling <ticotimo@gmail.com> | 2014-07-15 16:32:34 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:49 +0200 |
commit | a6d7ba92645a112af358efd94ff3aa0c74985a51 (patch) | |
tree | 6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-matplotlib | |
parent | ed634d36d64af846b68424d38eaa86b464584840 (diff) | |
download | meta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz |
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not
depended upon by recipes already in meta-oe (e.g. gateone,
anki)
* Recipes NOT moved:
python-futures
python-pyopenssl
python-simplejson
python-tornado
python-pyqt
python-sip
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-matplotlib')
-rw-r--r-- | meta-python/recipes-python/python/python-matplotlib/fix_setup.patch | 29 | ||||
-rw-r--r-- | meta-python/recipes-python/python/python-matplotlib/fix_setupext.patch | 29 |
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-matplotlib/fix_setup.patch b/meta-python/recipes-python/python/python-matplotlib/fix_setup.patch new file mode 100644 index 0000000000..9381583537 --- /dev/null +++ b/meta-python/recipes-python/python/python-matplotlib/fix_setup.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | This fixes the dependency checks inside of setup.py since things like | ||
2 | 'import numpy' won't work with bitbake. | ||
3 | |||
4 | diff --git a/setup.py b/setup.py | ||
5 | index 2f13821..e6d6ed0 100644 | ||
6 | --- a/setup.py | ||
7 | +++ b/setup.py | ||
8 | @@ -113,12 +113,6 @@ if 1: | ||
9 | baseline_images = [chop_package(f) for f in baseline_images] | ||
10 | package_data['matplotlib'].extend(baseline_images) | ||
11 | |||
12 | -if not check_for_numpy(): | ||
13 | - sys.exit(1) | ||
14 | - | ||
15 | -if not check_for_freetype(): | ||
16 | - sys.exit(1) | ||
17 | - | ||
18 | build_ft2font(ext_modules, packages) | ||
19 | build_ttconv(ext_modules, packages) | ||
20 | build_contour(ext_modules, packages) | ||
21 | @@ -129,7 +123,7 @@ build_tri(ext_modules, packages) | ||
22 | |||
23 | print_raw("") | ||
24 | print_raw("OPTIONAL BACKEND DEPENDENCIES") | ||
25 | -has_libpng = check_for_libpng() | ||
26 | +has_libpng = True | ||
27 | |||
28 | if has_libpng and options['build_agg']: | ||
29 | build_agg(ext_modules, packages) | ||
diff --git a/meta-python/recipes-python/python/python-matplotlib/fix_setupext.patch b/meta-python/recipes-python/python/python-matplotlib/fix_setupext.patch new file mode 100644 index 0000000000..e07159552f --- /dev/null +++ b/meta-python/recipes-python/python/python-matplotlib/fix_setupext.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | This fixes the numpy import problem in setupext.py using a hard-coded path. | ||
2 | |||
3 | diff --git a/setupext.py b/setupext.py | ||
4 | index 962cedc..82297c4 100644 | ||
5 | --- a/setupext.py | ||
6 | +++ b/setupext.py | ||
7 | @@ -176,10 +176,7 @@ if os.path.exists(setup_cfg): | ||
8 | except: pass | ||
9 | |||
10 | # For get_base_flags: | ||
11 | -if options['basedirlist']: | ||
12 | - basedirlist = options['basedirlist'].split() | ||
13 | -else: | ||
14 | - basedirlist = basedir[sys.platform] | ||
15 | +basedirlist = [os.environ['STAGING_LIBDIR']] | ||
16 | print("basedirlist is: %s" % basedirlist) | ||
17 | |||
18 | if options['display_status']: | ||
19 | @@ -555,8 +552,8 @@ def check_for_numpy(): | ||
20 | |||
21 | def add_numpy_flags(module): | ||
22 | "Add the modules flags to build extensions which use numpy" | ||
23 | - import numpy | ||
24 | - module.include_dirs.append(numpy.get_include()) | ||
25 | + # Hard-coded path for OE since I know this is where numpy's include dir will be | ||
26 | + module.include_dirs.append(os.path.join(os.environ['STAGING_LIBDIR'], 'python2.7/site-packages/numpy/core/include/')) | ||
27 | |||
28 | def add_png_flags(module): | ||
29 | try_pkgconfig(module, 'libpng', 'png') | ||