summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-matplotlib_1.1.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-07-15 16:32:34 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:49 +0200
commita6d7ba92645a112af358efd94ff3aa0c74985a51 (patch)
tree6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-matplotlib_1.1.0.bb
parented634d36d64af846b68424d38eaa86b464584840 (diff)
downloadmeta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-matplotlib_1.1.0.bb')
-rw-r--r--meta-python/recipes-python/python/python-matplotlib_1.1.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-matplotlib_1.1.0.bb b/meta-python/recipes-python/python/python-matplotlib_1.1.0.bb
new file mode 100644
index 0000000000..7bb61fd57e
--- /dev/null
+++ b/meta-python/recipes-python/python/python-matplotlib_1.1.0.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://README.txt;md5=83c5bf8b16a5f99507f2f47a21ae3b81"
5PR = "r1"
6
7DEPENDS += "python-numpy freetype libpng"
8RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/matplotlib/matplotlib-${PV}.tar.gz \
11 file://fix_setup.patch \
12 file://fix_setupext.patch \
13"
14
15S = "${WORKDIR}/matplotlib-${PV}"
16
17EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
18
19inherit distutils
20
21do_compile_prepend() {
22 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
23 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
24 true
25}
26
27# need to export these variables for python-config to work
28export PYTHONPATH
29export BUILD_SYS
30export HOST_SYS
31export STAGING_INCDIR
32export STAGING_LIBDIR
33
34
35SRC_URI[md5sum] = "57a627f30b3b27821f808659889514c2"
36SRC_URI[sha256sum] = "be37e1d86c65ecacae6683f8805e051e9904e5f2e02bf2b7a34262c46a6d06a7"