diff options
author | Tim Orling <ticotimo@gmail.com> | 2014-07-15 16:32:34 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:49 +0200 |
commit | a6d7ba92645a112af358efd94ff3aa0c74985a51 (patch) | |
tree | 6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-numeric | |
parent | ed634d36d64af846b68424d38eaa86b464584840 (diff) | |
download | meta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz |
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not
depended upon by recipes already in meta-oe (e.g. gateone,
anki)
* Recipes NOT moved:
python-futures
python-pyopenssl
python-simplejson
python-tornado
python-pyqt
python-sip
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-numeric')
-rw-r--r-- | meta-python/recipes-python/python/python-numeric/no-lapack.patch | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-numeric/no-lapack.patch b/meta-python/recipes-python/python/python-numeric/no-lapack.patch new file mode 100644 index 0000000000..c1916b8b9f --- /dev/null +++ b/meta-python/recipes-python/python/python-numeric/no-lapack.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- Numeric-23.7/setup.py~nolapack | ||
7 | +++ Numeric-23.7/setup.py | ||
8 | @@ -32,7 +32,7 @@ | ||
9 | mathlibs = [] | ||
10 | |||
11 | # delete all but the first one in this list if using your own LAPACK/BLAS | ||
12 | -sourcelist = [os.path.join('Src', 'lapack_litemodule.c'), | ||
13 | +sourcelist = [ | ||
14 | #os.path.join('Src', 'blas_lite.c'), | ||
15 | #os.path.join('Src', 'f2c_lite.c'), | ||
16 | #os.path.join('Src', 'zlapack_lite.c'), | ||
17 | @@ -40,12 +40,12 @@ | ||
18 | ] | ||
19 | # set these to use your own BLAS; | ||
20 | |||
21 | -library_dirs_list = ['/usr/lib/atlas'] | ||
22 | -libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c'] | ||
23 | +library_dirs_list = [] | ||
24 | +libraries_list = [] | ||
25 | |||
26 | # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct | ||
27 | -use_dotblas = 1 | ||
28 | -include_dirs = ['/usr/include/atlas'] | ||
29 | +use_dotblas = 0 | ||
30 | +include_dirs = [] | ||
31 | # You may need to set this to find cblas.h | ||
32 | # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas'] | ||
33 | extra_link_args = [] | ||