diff options
author | Tim Orling <ticotimo@gmail.com> | 2014-07-15 16:32:34 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:49 +0200 |
commit | a6d7ba92645a112af358efd94ff3aa0c74985a51 (patch) | |
tree | 6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-pyyaml/setup.py | |
parent | ed634d36d64af846b68424d38eaa86b464584840 (diff) | |
download | meta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz |
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not
depended upon by recipes already in meta-oe (e.g. gateone,
anki)
* Recipes NOT moved:
python-futures
python-pyopenssl
python-simplejson
python-tornado
python-pyqt
python-sip
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-pyyaml/setup.py')
-rw-r--r-- | meta-python/recipes-python/python/python-pyyaml/setup.py | 64 |
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-pyyaml/setup.py b/meta-python/recipes-python/python/python-pyyaml/setup.py new file mode 100644 index 0000000000..fb64983419 --- /dev/null +++ b/meta-python/recipes-python/python/python-pyyaml/setup.py | |||
@@ -0,0 +1,64 @@ | |||
1 | NAME = 'PyYAML' | ||
2 | VERSION = '3.06' | ||
3 | DESCRIPTION = "YAML parser and emitter for Python" | ||
4 | LONG_DESCRIPTION = """\ | ||
5 | YAML is a data serialization format designed for human readability and | ||
6 | interaction with scripting languages. PyYAML is a YAML parser and | ||
7 | emitter for Python. | ||
8 | |||
9 | PyYAML features a complete YAML 1.1 parser, Unicode support, pickle | ||
10 | support, capable extension API, and sensible error messages. PyYAML | ||
11 | supports standard YAML tags and provides Python-specific tags that allow | ||
12 | to represent an arbitrary Python object. | ||
13 | |||
14 | PyYAML is applicable for a broad range of tasks from complex | ||
15 | configuration files to object serialization and persistance.""" | ||
16 | AUTHOR = "Kirill Simonov" | ||
17 | AUTHOR_EMAIL = 'xi@resolvent.net' | ||
18 | LICENSE = "MIT" | ||
19 | PLATFORMS = "Any" | ||
20 | URL = "http://pyyaml.org/wiki/PyYAML" | ||
21 | DOWNLOAD_URL = "http://pyyaml.org/download/pyyaml/%s-%s.tar.gz" % (NAME, VERSION) | ||
22 | CLASSIFIERS = [ | ||
23 | "Development Status :: 5 - Production/Stable", | ||
24 | "Intended Audience :: Developers", | ||
25 | "License :: OSI Approved :: MIT License", | ||
26 | "Operating System :: OS Independent", | ||
27 | "Programming Language :: Python", | ||
28 | "Topic :: Software Development :: Libraries :: Python Modules", | ||
29 | "Topic :: Text Processing :: Markup", | ||
30 | ] | ||
31 | |||
32 | from distutils.core import setup | ||
33 | from distutils.extension import Extension | ||
34 | from Cython.Distutils import build_ext | ||
35 | |||
36 | import sys, os.path | ||
37 | |||
38 | |||
39 | if __name__ == '__main__': | ||
40 | |||
41 | setup( | ||
42 | name=NAME, | ||
43 | version=VERSION, | ||
44 | description=DESCRIPTION, | ||
45 | long_description=LONG_DESCRIPTION, | ||
46 | author=AUTHOR, | ||
47 | author_email=AUTHOR_EMAIL, | ||
48 | license=LICENSE, | ||
49 | platforms=PLATFORMS, | ||
50 | url=URL, | ||
51 | download_url=DOWNLOAD_URL, | ||
52 | classifiers=CLASSIFIERS, | ||
53 | |||
54 | package_dir={'': 'lib'}, | ||
55 | packages=['yaml'], | ||
56 | |||
57 | ext_modules = [ | ||
58 | Extension( "_yaml", ["ext/_yaml.pyx"], libraries = ["yaml"] ) | ||
59 | ], | ||
60 | |||
61 | cmdclass={ | ||
62 | 'build_ext': build_ext, | ||
63 | }, | ||
64 | ) | ||