summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-smbus_3.0.3.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-07-15 16:32:34 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:49 +0200
commita6d7ba92645a112af358efd94ff3aa0c74985a51 (patch)
tree6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-smbus_3.0.3.bb
parented634d36d64af846b68424d38eaa86b464584840 (diff)
downloadmeta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-smbus_3.0.3.bb')
-rw-r--r--meta-python/recipes-python/python/python-smbus_3.0.3.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-smbus_3.0.3.bb b/meta-python/recipes-python/python/python-smbus_3.0.3.bb
new file mode 100644
index 0000000000..14548a9635
--- /dev/null
+++ b/meta-python/recipes-python/python/python-smbus_3.0.3.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Set of i2c tools for linux - Python module"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://smbusmodule.c;startline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8"
4
5SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/i2c-tools-${PV}.tar.bz2 \
6"
7SRC_URI[md5sum] = "511376eed04455cdb277ef19c5f73bb4"
8SRC_URI[sha256sum] = "23b28e474741834e3f1b35b0686528769a13adc92d2ff5603cbda1d6bd5e5629"
9
10DEPENDS = "i2c-tools"
11
12inherit distutils
13
14S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
15
16do_configure_prepend() {
17 # Adjust for OE header rename
18 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: Module.mk
19 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: smbusmodule.c
20}