diff options
author | Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | 2020-04-04 01:46:15 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-03 14:38:09 -0700 |
commit | 00e16173308d409acbe15cde261cc502017e2eca (patch) | |
tree | afa8973979f74a0b9d9b1d0c1fab954d439b5131 /meta-python | |
parent | a383dd710cc8e2d81a4377788c2bb6b31aee591b (diff) | |
download | meta-openembedded-00e16173308d409acbe15cde261cc502017e2eca.tar.gz |
python3-precise-runner: Enable ptest
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-precise-runner/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-precise-runner/run-ptest b/meta-python/recipes-devtools/python/python3-precise-runner/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-precise-runner/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb b/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb index 98b62d899c..6155b79818 100644 --- a/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb +++ b/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb | |||
@@ -6,4 +6,17 @@ LIC_FILES_CHKSUM = "file://README.md;md5=2ad29e930f3107d52d2a55728bf62116" | |||
6 | SRC_URI[md5sum] = "a2434be110444192e804f4dada0ccecf" | 6 | SRC_URI[md5sum] = "a2434be110444192e804f4dada0ccecf" |
7 | SRC_URI[sha256sum] = "1a464209fb4bf0a3f5d5a428310cb2a70487a01a6bc3a960d1dda90af896b80d" | 7 | SRC_URI[sha256sum] = "1a464209fb4bf0a3f5d5a428310cb2a70487a01a6bc3a960d1dda90af896b80d" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | inherit pypi setuptools3 ptest |
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | RDEPENDS_${PN}-ptest += " \ | ||
16 | ${PYTHON_PN}-pytest \ | ||
17 | " | ||
18 | |||
19 | do_install_ptest() { | ||
20 | install -d ${D}${PTEST_PATH}/test | ||
21 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ | ||
22 | } | ||