diff options
author | Bill Randle <bill.randle@gmail.com> | 2017-11-29 21:47:00 -0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-11 07:58:58 -0800 |
commit | 04590bdc1db6e2ad7b526aa6fd1749f28784cb6c (patch) | |
tree | 84793b2551889bbff095d08712bf585ea49b6d1f /meta-python | |
parent | f00a7b9e7037f5e3efed10b1c81371b69dd0dee9 (diff) | |
download | meta-openembedded-04590bdc1db6e2ad7b526aa6fd1749f28784cb6c.tar.gz |
python-dominate: move core of recipe to a .inc file
Signed-off-by: Bill Randle <bill.randle@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-dominate.inc | 11 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-dominate_2.3.1.bb | 13 |
2 files changed, 12 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python-dominate.inc b/meta-python/recipes-devtools/python/python-dominate.inc new file mode 100644 index 0000000000..ecf74a0bc5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-dominate.inc | |||
@@ -0,0 +1,11 @@ | |||
1 | SUMMARY = "Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API." | ||
2 | LICENSE = "LGPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24" | ||
4 | |||
5 | SRC_URI[md5sum] = "45bd97e6f7888aac24ae86013c57638e" | ||
6 | SRC_URI[sha256sum] = "4b8ce6f33633c9dd9175b228d21c00c801b6bd0327747cd5e17fc2da934c3a69" | ||
7 | |||
8 | RDEPENDS_${PN} += "\ | ||
9 | ${PYTHON_PN}-numbers \ | ||
10 | ${PYTHON_PN}-threading \ | ||
11 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-dominate_2.3.1.bb b/meta-python/recipes-devtools/python/python-dominate_2.3.1.bb index 13ebf92b65..c19445e728 100644 --- a/meta-python/recipes-devtools/python/python-dominate_2.3.1.bb +++ b/meta-python/recipes-devtools/python/python-dominate_2.3.1.bb | |||
@@ -1,13 +1,2 @@ | |||
1 | SUMMARY = "Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API." | ||
2 | LICENSE = "LGPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24" | ||
4 | |||
5 | SRC_URI[md5sum] = "45bd97e6f7888aac24ae86013c57638e" | ||
6 | SRC_URI[sha256sum] = "4b8ce6f33633c9dd9175b228d21c00c801b6bd0327747cd5e17fc2da934c3a69" | ||
7 | |||
8 | inherit pypi setuptools | 1 | inherit pypi setuptools |
9 | 2 | require python-dominate.inc | |
10 | RDEPENDS_${PN} += "\ | ||
11 | ${PYTHON_PN}-numbers \ | ||
12 | ${PYTHON_PN}-threading \ | ||
13 | " | ||