diff options
author | Pascal Bach <pascal.bach@nextrem.ch> | 2017-01-09 10:33:17 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-01-25 15:58:55 +0100 |
commit | 0afa43b350f2ac87bded60a9d88e0776e1e6edb5 (patch) | |
tree | ed4422dfe95bf747e6bbf74a0cca9f35ada024e3 /meta-python | |
parent | 13447acd1c400778f90d1c57130923cd5014f178 (diff) | |
download | meta-openembedded-0afa43b350f2ac87bded60a9d88e0776e1e6edb5.tar.gz |
python-sqlalchemy: update to 1.1.4 and provide python2 and python3 package
The license hash change is due to a bump in the copyright year
Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
4 files changed, 17 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy.inc b/meta-python/recipes-devtools/python/python-sqlalchemy.inc new file mode 100755 index 0000000000..471c109f92 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-sqlalchemy.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \ | ||
2 | application developers the full power and flexibility of SQL" | ||
3 | HOMEPAGE = "http://www.sqlalchemy.org/" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d7dba1721bc8ce05d421f7279cb87971" | ||
6 | |||
7 | PYPI_PACKAGE = "SQLAlchemy" | ||
8 | inherit pypi | ||
9 | |||
10 | SRC_URI[md5sum] = "be5af1bebe595206b71b513a14836e4f" | ||
11 | SRC_URI[sha256sum] = "701b57d628b9fa1cfb82f10665e7214d5d2db23251ca6f23b91c5f56fcdbdeb5" | ||
12 | |||
13 | RDEPENDS_${PN} += "${PYTHON_PN}-numbers" | ||
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy_0.7.9.bb b/meta-python/recipes-devtools/python/python-sqlalchemy_0.7.9.bb deleted file mode 100644 index 43b4b7efa2..0000000000 --- a/meta-python/recipes-devtools/python/python-sqlalchemy_0.7.9.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \ | ||
2 | application developers the full power and flexibility of SQL" | ||
3 | HOMEPAGE = "http://www.sqlalchemy.org/" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=baffc5e5f4804c92fc9be155fed70d41" | ||
6 | RDEPENDS_${PN} += "python-numbers" | ||
7 | |||
8 | SRCNAME = "SQLAlchemy" | ||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/sqlalchemy/${SRCNAME}-${PV}.tar.gz" | ||
10 | SRC_URI[md5sum] = "c4852d586d95a59fbc9358f4467875d5" | ||
11 | SRC_URI[sha256sum] = "f7a305ad122144f364ce09a2d9ed5159d5f46ec43650653593e7dfa05d3294a1" | ||
12 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
13 | |||
14 | inherit setuptools | ||
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb b/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb new file mode 100755 index 0000000000..53c8fecf70 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-sqlalchemy.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb new file mode 100755 index 0000000000..86cf9eddeb --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-sqlalchemy.inc | ||