diff options
author | Zang Ruochen <zangrc.fnst@cn.fujitsu.com> | 2020-07-17 03:43:17 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-07-16 12:10:32 -0700 |
commit | 0fdee019fd5c90abd057b9c47f6a6d6786caec5c (patch) | |
tree | 15d61a15bcc6f823d82105181c55307355b2594e /meta-python | |
parent | ab11bdfe0513579098553f8dd9569f8a6b39850a (diff) | |
download | meta-openembedded-0fdee019fd5c90abd057b9c47f6a6d6786caec5c.tar.gz |
python3-semver: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-semver/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-semver_2.10.2.bb | 14 |
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-semver/run-ptest b/meta-python/recipes-devtools/python/python3-semver/run-ptest new file mode 100644 index 0000000000..43c03b594b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-semver/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO test_semver.py --disable-warnings| sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb b/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb index b41ef5ddc7..71cb1acec3 100644 --- a/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb +++ b/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb | |||
@@ -7,6 +7,18 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665 | |||
7 | SRC_URI[md5sum] = "3e11ae9782121e8ffe9f8a8b763a8cb5" | 7 | SRC_URI[md5sum] = "3e11ae9782121e8ffe9f8a8b763a8cb5" |
8 | SRC_URI[sha256sum] = "c0a4a9d1e45557297a722ee9bac3de2ec2ea79016b6ffcaca609b0bc62cf4276" | 8 | SRC_URI[sha256sum] = "c0a4a9d1e45557297a722ee9bac3de2ec2ea79016b6ffcaca609b0bc62cf4276" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 ptest |
11 | 11 | ||
12 | BBCLASSEXTEND = "native nativesdk" | 12 | BBCLASSEXTEND = "native nativesdk" |
13 | |||
14 | SRC_URI += " \ | ||
15 | file://run-ptest \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS_${PN}-ptest += " \ | ||
19 | ${PYTHON_PN}-pytest \ | ||
20 | " | ||
21 | |||
22 | do_install_ptest() { | ||
23 | cp -f ${S}/test_semver.py ${D}${PTEST_PATH}/ | ||
24 | } | ||