diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2018-07-31 12:15:25 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-02 11:23:02 -0700 |
commit | 19aeaf028f6819e5fa705593d4bcdbf0b98143e0 (patch) | |
tree | c82e078c174dbeb7a7e1baafd0e94700d89a02e4 /meta-python | |
parent | a74abf155d7bd6c873fd72b76369c09e5c68031c (diff) | |
download | meta-openembedded-19aeaf028f6819e5fa705593d4bcdbf0b98143e0.tar.gz |
python-{m2crypto, protobuf, slip-dbus}, lio-utils: add CLEANBROKEN
* these are failing after distutils started calling clean in:
http://git.openembedded.org/openembedded-core/commit/?id=57414f4a1c549e6faaa110e6e95ff601b05b7361
http://git.openembedded.org/openembedded-core/commit/?id=9d556092fcc6f04c487afd126d52935bac133165
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.26.4.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.26.4.bb index 272c76ca17..899a361bd8 100644 --- a/meta-python/recipes-devtools/python/python-m2crypto_0.26.4.bb +++ b/meta-python/recipes-devtools/python/python-m2crypto_0.26.4.bb | |||
@@ -48,3 +48,7 @@ do_compile_prepend() { | |||
48 | } | 48 | } |
49 | 49 | ||
50 | BBCLASSEXTEND = "native" | 50 | BBCLASSEXTEND = "native" |
51 | |||
52 | # http://errors.yoctoproject.org/Errors/Details/184714/ | ||
53 | # SWIG/_m2crypto.i:10: Error: Unable to find 'gcc_macros.h' | ||
54 | CLEANBROKEN = "1" | ||
diff --git a/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb b/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb index dc0823fd23..dddc9bbb58 100644 --- a/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb +++ b/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb | |||
@@ -1,3 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-protobuf.inc | 2 | require python-protobuf.inc |
3 | 3 | ||
4 | # http://errors.yoctoproject.org/Errors/Details/184715/ | ||
5 | # Can't find required file: ../src/google/protobuf/descriptor.proto | ||
6 | CLEANBROKEN = "1" | ||
diff --git a/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb index 8081416ee4..dc587e761e 100644 --- a/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb +++ b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.1.bb | |||
@@ -25,3 +25,7 @@ SRC_URI[sha256sum] = "bc897f1ab6f5b4989f85548799aaeb84fde67bbba18e40341bfe1d7885 | |||
25 | do_compile_prepend() { | 25 | do_compile_prepend() { |
26 | sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py | 26 | sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py |
27 | } | 27 | } |
28 | |||
29 | # http://errors.yoctoproject.org/Errors/Details/184713/ | ||
30 | # python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory | ||
31 | CLEANBROKEN = "1" | ||