diff options
author | Marc Ferland <ferlandm@amotus.ca> | 2017-05-01 11:32:08 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-05-04 09:18:58 +0200 |
commit | 1e322de8e68a50a14bb1d4be83912e1a437daf3a (patch) | |
tree | 36e9a67dd011702d7dde98991df40d28d7509ac1 /meta-python | |
parent | 3af551405e044ec77b85f50a6a33a8ed3b56f8e4 (diff) | |
download | meta-openembedded-1e322de8e68a50a14bb1d4be83912e1a437daf3a.tar.gz |
python-prettytable: fix files permissions
Got this runtime error:
IOError: [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/prettytable-0.7.2-py2.7.egg-info/PKG-INFO'
After some investigation, it looks like the pypi package is the culprit
as almost all the files in the tar.gz are set to 600 instead of 644.
Signed-off-by: Marc Ferland <ferlandm@amotus.ca>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb b/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb index f63457efe5..6f4390e24c 100644 --- a/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb +++ b/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb | |||
@@ -15,7 +15,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}" | |||
15 | inherit setuptools | 15 | inherit setuptools |
16 | 16 | ||
17 | do_install_append() { | 17 | do_install_append() { |
18 | perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"` | 18 | perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"` |
19 | for f in $perm_files; do | 19 | for f in $perm_files; do |
20 | chmod 644 "${f}" | 20 | chmod 644 "${f}" |
21 | done | 21 | done |