summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-04-28 10:09:13 -0300
committerKhem Raj <raj.khem@gmail.com>2020-04-28 16:24:07 -0700
commit22d74cb158949dca9008ae0a27fef212bfc2310a (patch)
tree373d8f98de6d42e456e317e0f539bad868951890 /meta-python
parent5ec6b7b7655df368b116f8c69c5156ce9c1aa3ab (diff)
downloadmeta-openembedded-22d74cb158949dca9008ae0a27fef212bfc2310a.tar.gz
python3-werkzeug: Upgrade 1.0.0 -> 1.0.1
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
new file mode 100644
index 0000000000..b54399e1c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "The Swiss Army knife of Python web development"
2DESCRIPTION = "\
3Werkzeug started as simple collection of various utilities for WSGI \
4applications and has become one of the most advanced WSGI utility modules. \
5It includes a powerful debugger, full featured request and response objects, \
6HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
7cookie handling, file uploads, a powerful URL routing system and a bunch \
8of community contributed addon modules."
9HOMEPAGE = "http://werkzeug.pocoo.org/"
10LICENSE = "BSD"
11LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
12
13PYPI_PACKAGE = "Werkzeug"
14
15SRC_URI[md5sum] = "5d499cfdd30de5d9c946994783772efd"
16SRC_URI[sha256sum] = "6c80b1e5ad3665290ea39320b91e1be1e0d5f60652b964a3070216de83d2e47c"
17
18inherit pypi setuptools3
19
20CLEANBROKEN = "1"
21
22RDEPENDS_${PN} += " \
23 ${PYTHON_PN}-datetime \
24 ${PYTHON_PN}-difflib \
25 ${PYTHON_PN}-email \
26 ${PYTHON_PN}-html \
27 ${PYTHON_PN}-io \
28 ${PYTHON_PN}-json \
29 ${PYTHON_PN}-netclient \
30 ${PYTHON_PN}-netserver \
31 ${PYTHON_PN}-numbers \
32 ${PYTHON_PN}-pkgutil \
33 ${PYTHON_PN}-pprint \
34 ${PYTHON_PN}-simplejson \
35 ${PYTHON_PN}-threading \
36 ${PYTHON_PN}-unixadmin \
37 ${PYTHON_PN}-misc \
38"