diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-07-02 13:48:19 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-07-06 10:20:11 -0700 |
commit | 259b20be6420281d2df3bfadd176d603592c89cc (patch) | |
tree | b3474fc65ae0ec4dc12f7507939e9122624c1537 /meta-python | |
parent | 3659e48241bb9a54c734bf5ca613a2901a483183 (diff) | |
download | meta-openembedded-259b20be6420281d2df3bfadd176d603592c89cc.tar.gz |
python3-h5py: Upgrade 2.9.0 -> 2.10.0
Inherit pypi. Use LICENSE for LIC_FILES_CHKSUM.
Upgrade to release 2.10.0, for details:
http://docs.h5py.org/en/stable/whatsnew/index.html
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch | 15 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb (renamed from meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb) | 16 |
2 files changed, 16 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch index ff50c85a06..8c0b914326 100644 --- a/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch +++ b/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 7e3b1745c1fef34683a0610381dd3308ad4d1ba9 Mon Sep 17 00:00:00 2001 | 1 | From 364fd0906efa349ea44a761820408dcf6b2b8726 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Tue, 29 Jan 2019 17:08:32 +0800 | 3 | Date: Tue, 29 Jan 2019 17:08:32 +0800 |
4 | Subject: [PATCH] cross compiling support | 4 | Subject: [PATCH] cross compiling support |
@@ -8,16 +8,17 @@ Remove useless dirs | |||
8 | Upstream-Status: Inappropriate [oe specific] | 8 | Upstream-Status: Inappropriate [oe specific] |
9 | 9 | ||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
11 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
11 | --- | 12 | --- |
12 | setup_build.py | 4 ---- | 13 | setup_build.py | 4 ---- |
13 | setup_configure.py | 2 +- | 14 | setup_configure.py | 2 +- |
14 | 2 files changed, 1 insertion(+), 5 deletions(-) | 15 | 2 files changed, 1 insertion(+), 5 deletions(-) |
15 | 16 | ||
16 | diff --git a/setup_build.py b/setup_build.py | 17 | diff --git a/setup_build.py b/setup_build.py |
17 | index 85b321a..2c78e92 100644 | 18 | index c0e9a28c..ffd3bef7 100644 |
18 | --- a/setup_build.py | 19 | --- a/setup_build.py |
19 | +++ b/setup_build.py | 20 | +++ b/setup_build.py |
20 | @@ -53,10 +53,6 @@ if sys.platform.startswith('win'): | 21 | @@ -55,10 +55,6 @@ if sys.platform.startswith('win'): |
21 | ('_HDF5USEDLL_', None), | 22 | ('_HDF5USEDLL_', None), |
22 | ('H5_BUILT_AS_DYNAMIC_LIB', None) | 23 | ('H5_BUILT_AS_DYNAMIC_LIB', None) |
23 | ]) | 24 | ]) |
@@ -29,11 +30,11 @@ index 85b321a..2c78e92 100644 | |||
29 | class h5py_build_ext(build_ext): | 30 | class h5py_build_ext(build_ext): |
30 | 31 | ||
31 | diff --git a/setup_configure.py b/setup_configure.py | 32 | diff --git a/setup_configure.py b/setup_configure.py |
32 | index a2de76a..197f2da 100644 | 33 | index 5576775e..75f4141e 100644 |
33 | --- a/setup_configure.py | 34 | --- a/setup_configure.py |
34 | +++ b/setup_configure.py | 35 | +++ b/setup_configure.py |
35 | @@ -208,7 +208,7 @@ def autodetect_version(hdf5_dir=None): | 36 | @@ -206,7 +206,7 @@ def autodetect_version(hdf5_dir=None): |
36 | else: | 37 | default_path = 'libhdf5.so' |
37 | regexp = re.compile(r'^libhdf5.so') | 38 | regexp = re.compile(r'^libhdf5.so') |
38 | 39 | ||
39 | - libdirs = ['/usr/local/lib', '/opt/local/lib'] | 40 | - libdirs = ['/usr/local/lib', '/opt/local/lib'] |
@@ -42,5 +43,5 @@ index a2de76a..197f2da 100644 | |||
42 | if pkgconfig.exists("hdf5"): | 43 | if pkgconfig.exists("hdf5"): |
43 | libdirs.extend(pkgconfig.parse("hdf5")['library_dirs']) | 44 | libdirs.extend(pkgconfig.parse("hdf5")['library_dirs']) |
44 | -- | 45 | -- |
45 | 2.7.4 | 46 | 2.17.1 |
46 | 47 | ||
diff --git a/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb index 7822e463ee..3904abbb48 100644 --- a/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb +++ b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb | |||
@@ -1,17 +1,17 @@ | |||
1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python. " | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
2 | HOMEPAGE = "https://www.h5py.org/" | 2 | HOMEPAGE = "https://www.h5py.org/" |
3 | SECTION = "devel/python" | 3 | SECTION = "devel/python" |
4 | LICENSE = "BSD-3-Clause" | 4 | LICENSE = "BSD-3-Clause" |
5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=795ecad0d261c998cc526c84a822dff6" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
6 | 6 | ||
7 | SRC_URI = "git://github.com/h5py/h5py.git \ | 7 | SRC_URI[md5sum] = "504b595237409ab766fbbe568e60a080" |
8 | SRC_URI[sha256sum] = "84412798925dc870ffd7107f045d7659e60f5d46d1c70c700375248bf6bf512d" | ||
9 | |||
10 | SRC_URI_append = " \ | ||
8 | file://0001-cross-compiling-support.patch \ | 11 | file://0001-cross-compiling-support.patch \ |
9 | " | 12 | " |
10 | SRCREV ?= "8d96a14c3508de1bde77aec5db302e478dc5dbc4" | ||
11 | |||
12 | inherit setuptools3 | ||
13 | 13 | ||
14 | S = "${WORKDIR}/git" | 14 | inherit pypi setuptools3 |
15 | 15 | ||
16 | BBCLASSEXTEND = "native" | 16 | BBCLASSEXTEND = "native" |
17 | 17 | ||
@@ -27,4 +27,4 @@ RDEPENDS_${PN} = "python3-numpy \ | |||
27 | python3-six \ | 27 | python3-six \ |
28 | " | 28 | " |
29 | 29 | ||
30 | export HDF5_VERSION="1.8.19" | 30 | export HDF5_VERSION="1.8.21" |