summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJonathan Richardson via Openembedded-devel <openembedded-devel@lists.openembedded.org>2020-02-14 17:18:09 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit2b135892fafe92f28e0f1719c3ad5f952a4e30df (patch)
tree218546dfe0669bcaa16e158d9554240811326153 /meta-python
parenta939ec7cbb336b2ae1317e5863cf15f4c8157c9e (diff)
downloadmeta-openembedded-2b135892fafe92f28e0f1719c3ad5f952a4e30df.tar.gz
python3-et-xmlfile: add initial recipe version 1.0.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb b/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
new file mode 100644
index 0000000000..cfff150cc7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "et_xmlfile is a low memory library for creating large XML files"
2DESCRIPTION = "It is based upon the xmlfile module from lxml with the aim of allowing code \
3to be developed that will work with both libraries. It was developed initially for \
4the openpyxl project but is now a standalone module."
5
6HOMEPAGE = "https://bitbucket.org/openpyxl/et_xmlfile/src/default/"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://PKG-INFO;md5=b3d89cae66f26c3a0799be8a96f3178b"
9
10SRC_URI[md5sum] = "f47940fd9d556375420b2e276476cfaf"
11SRC_URI[sha256sum] = "614d9722d572f6246302c4491846d2c393c199cfa4edc9af593437691683335b"
12
13RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
14
15inherit setuptools3
16PYPI_PACKAGE ?= "et_xmlfile"
17PYPI_SRC_URI ?= "https://files.pythonhosted.org/packages/source/e/et_xmlfile/et_xmlfile-1.0.1.tar.gz"
18SECTION = "devel/python"
19SRC_URI += "${PYPI_SRC_URI}"
20S = "${WORKDIR}/${PYPI_PACKAGE}-${PV}"