diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-09-24 23:09:25 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-09-26 06:58:28 -0700 |
commit | 2c11a99e938dbb24901918f4519337571e6f72b1 (patch) | |
tree | 1125565838c5591b7f8ba0b82fc0013db061157d /meta-python | |
parent | d1a2b7ec56d1e052bea2f716215d9cfb6aa3b683 (diff) | |
download | meta-openembedded-2c11a99e938dbb24901918f4519337571e6f72b1.tar.gz |
python3-starlette: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 45 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc index e500843e88..da6206c6ba 100644 --- a/meta-python/conf/include/ptest-packagelists-meta-python.inc +++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc | |||
@@ -72,6 +72,7 @@ PTESTS_FAST_META_PYTHON = "\ | |||
72 | python3-smpplib \ | 72 | python3-smpplib \ |
73 | python3-soupsieve \ | 73 | python3-soupsieve \ |
74 | python3-sqlparse \ | 74 | python3-sqlparse \ |
75 | python3-starlette \ | ||
75 | python3-tomli-w \ | 76 | python3-tomli-w \ |
76 | python3-tomlkit \ | 77 | python3-tomlkit \ |
77 | python3-trustme \ | 78 | python3-trustme \ |
diff --git a/meta-python/recipes-devtools/python/python3-starlette/run-ptest b/meta-python/recipes-devtools/python/python3-starlette/run-ptest new file mode 100644 index 0000000000..09bdf7cedf --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-starlette/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake --forked --deselect tests/test_staticfiles.py::test_staticfiles_with_invalid_dir_permissions_returns_401 | ||
diff --git a/meta-python/recipes-devtools/python/python3-starlette_0.39.0.bb b/meta-python/recipes-devtools/python/python3-starlette_0.39.0.bb new file mode 100644 index 0000000000..c4b3d99164 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-starlette_0.39.0.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "Starlette is a lightweight ASGI framework/toolkit, which is ideal for building async web services in Python" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=11e8c8dbfd5fa373c703de492140ff7a" | ||
4 | |||
5 | SRC_URI[sha256sum] = "b35acedae74e95967dd9c0a47b45f5803dcd8973d0d95c18c1abb184845ba42c" | ||
6 | |||
7 | inherit pypi python_hatchling ptest | ||
8 | |||
9 | PYPI_PACKAGE = "starlette" | ||
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | RDEPENDS:${PN}-ptest += " \ | ||
16 | python3-attrs \ | ||
17 | python3-ctypes \ | ||
18 | python3-httpx \ | ||
19 | python3-itsdangerous \ | ||
20 | python3-jinja2 \ | ||
21 | python3-outcome \ | ||
22 | python3-pytest \ | ||
23 | python3-pytest-asyncio \ | ||
24 | python3-pytest-forked \ | ||
25 | python3-python-multipart \ | ||
26 | python3-sortedcontainers \ | ||
27 | python3-terminal \ | ||
28 | python3-trio \ | ||
29 | python3-typing-extensions \ | ||
30 | python3-unittest-automake-output \ | ||
31 | python3-pyyaml \ | ||
32 | " | ||
33 | |||
34 | do_install_ptest() { | ||
35 | install -d ${D}${PTEST_PATH}/tests | ||
36 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
37 | } | ||
38 | |||
39 | RDEPENDS:${PN} += " \ | ||
40 | python3-anyio \ | ||
41 | " | ||