diff options
author | Zang Ruochen <zangrc.fnst@cn.fujitsu.com> | 2020-07-17 03:43:19 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-07-16 12:10:39 -0700 |
commit | 2c2c5ea042be2a453984c7bd456b2e4e97b7ac33 (patch) | |
tree | 384cb80b0786d911b7255ecafc323744949b4d9f /meta-python | |
parent | 5589e39dbe4f19e8cecd0a55d5f5130e953c3b08 (diff) | |
download | meta-openembedded-2c2c5ea042be2a453984c7bd456b2e4e97b7ac33.tar.gz |
python3-soupsieve: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-soupsieve/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-soupsieve_2.0.1.bb | 16 |
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve/run-ptest b/meta-python/recipes-devtools/python/python3-soupsieve/run-ptest new file mode 100644 index 0000000000..b63c4de0d9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-soupsieve/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve_2.0.1.bb b/meta-python/recipes-devtools/python/python3-soupsieve_2.0.1.bb index aa087c9200..ae242af562 100644 --- a/meta-python/recipes-devtools/python/python3-soupsieve_2.0.1.bb +++ b/meta-python/recipes-devtools/python/python3-soupsieve_2.0.1.bb | |||
@@ -7,6 +7,20 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5a6fd3b0c24fc5a041a3d1bbb22c81b5" | |||
7 | SRC_URI[md5sum] = "62a7481c7dbf6d8cc21e4e3a79c72034" | 7 | SRC_URI[md5sum] = "62a7481c7dbf6d8cc21e4e3a79c72034" |
8 | SRC_URI[sha256sum] = "a59dc181727e95d25f781f0eb4fd1825ff45590ec8ff49eadfd7f1a537cc0232" | 8 | SRC_URI[sha256sum] = "a59dc181727e95d25f781f0eb4fd1825ff45590ec8ff49eadfd7f1a537cc0232" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 ptest |
11 | |||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | RDEPENDS_${PN}-ptest += " \ | ||
17 | ${PYTHON_PN}-pytest \ | ||
18 | ${PYTHON_PN}-beautifulsoup4 \ | ||
19 | " | ||
20 | |||
21 | do_install_ptest() { | ||
22 | install -d ${D}${PTEST_PATH}/tests | ||
23 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
24 | } | ||
11 | 25 | ||
12 | BBCLASSEXTEND = "native nativesdk" | 26 | BBCLASSEXTEND = "native nativesdk" |