diff options
author | Zang Ruochen <zangrc.fnst@cn.fujitsu.com> | 2020-06-15 22:40:03 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-17 08:56:52 -0700 |
commit | 2da223d89b20a100f97b49b5840706755b978a28 (patch) | |
tree | 8340088d956327f067b63fa7cccc46befbd57e45 /meta-python | |
parent | 9b318ba90bcce48f4a87a71a4e05df14d5b6294b (diff) | |
download | meta-openembedded-2da223d89b20a100f97b49b5840706755b978a28.tar.gz |
python-html2text: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-html2text/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-html2text_2020.1.16.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-html2text/run-ptest b/meta-python/recipes-devtools/python/python3-html2text/run-ptest new file mode 100644 index 0000000000..b63c4de0d9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-html2text/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-html2text_2020.1.16.bb b/meta-python/recipes-devtools/python/python3-html2text_2020.1.16.bb index 565b31d979..ea17190d59 100644 --- a/meta-python/recipes-devtools/python/python3-html2text_2020.1.16.bb +++ b/meta-python/recipes-devtools/python/python3-html2text_2020.1.16.bb | |||
@@ -7,6 +7,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | |||
7 | SRC_URI[md5sum] = "c77b580c94d1a9e0145f23cc4472993d" | 7 | SRC_URI[md5sum] = "c77b580c94d1a9e0145f23cc4472993d" |
8 | SRC_URI[sha256sum] = "e296318e16b059ddb97f7a8a1d6a5c1d7af4544049a01e261731d2d5cc277bbb" | 8 | SRC_URI[sha256sum] = "e296318e16b059ddb97f7a8a1d6a5c1d7af4544049a01e261731d2d5cc277bbb" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 ptest |
11 | |||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | RDEPENDS_${PN}-ptest += " \ | ||
17 | ${PYTHON_PN}-pytest \ | ||
18 | " | ||
19 | |||
20 | do_install_ptest() { | ||
21 | install -d ${D}${PTEST_PATH}/test | ||
22 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ | ||
23 | } | ||
11 | 24 | ||
12 | BBCLASSEXTEND = "native nativesdk" | 25 | BBCLASSEXTEND = "native nativesdk" |