summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-15 18:24:50 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-16 12:10:20 -0700
commit32f5b2b03dd35885d036fa3f68eec1c4a7fd9c90 (patch)
tree0eee3280bfa4bac78c556b9c9c75292aefcbf3cf /meta-python
parent64275adde858caad29c330c1fddb4dbb689daf2a (diff)
downloadmeta-openembedded-32f5b2b03dd35885d036fa3f68eec1c4a7fd9c90.tar.gz
python3-bitarray: Upgrade 1.2.2 -> 1.4.1
Upgrade to release 1.4.1: * add `.clear()` method (Python 3.3 added this method to lists) * avoid overallocation when bitarray objects are initially created * raise BufferError when resizing bitarrays which is exporting buffers * add example to study the resize() function * improve some error messages * add more tests * raise `NotImplementedError` with (useful message) when trying to call the `.fromstring()` or `.tostring()` methods, which have been removed in the last release * add official Python 3.9 support * improve many docstrings * add DeprecationWarning for bitdiff() * add more tests * C-level: - simplify pack/unpack code - fix memory leak in '~' operation (bitarray_cpinvert) Use the exact line for the license in PKG-INFO. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_1.2.2.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_1.4.1.bb11
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_1.2.2.bb b/meta-python/recipes-devtools/python/python3-bitarray_1.2.2.bb
deleted file mode 100644
index c495738c40..0000000000
--- a/meta-python/recipes-devtools/python/python3-bitarray_1.2.2.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1SUMMARY = "A high-level Python efficient arrays of booleans -- C extension"
2HOMEPAGE = "https://github.com/ilanschnell/bitarray"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://PKG-INFO;md5=d331e1d54f5e78247388f5416c2ab928"
5
6SRC_URI[md5sum] = "81c48852b0bc538ac3ed25fae020360c"
7SRC_URI[sha256sum] = "27a69ffcee3b868abab3ce8b17c69e02b63e722d4d64ffd91d659f81e9984954"
8
9inherit setuptools3 pypi
10
11BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_1.4.1.bb b/meta-python/recipes-devtools/python/python3-bitarray_1.4.1.bb
new file mode 100644
index 0000000000..4866e8464d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitarray_1.4.1.bb
@@ -0,0 +1,11 @@
1SUMMARY = "A high-level Python efficient arrays of booleans -- C extension"
2HOMEPAGE = "https://github.com/ilanschnell/bitarray"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d"
5
6SRC_URI[md5sum] = "dfb3fe66ae989e4724747fcb0f704f56"
7SRC_URI[sha256sum] = "9e26d3dc7fad932fed66e08da3fcf93dd15e8402aa84e764e1e2a9e1b6ae2b7f"
8
9inherit setuptools3 pypi
10
11BBCLASSEXTEND = "native nativesdk"