summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-07 13:08:46 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-07 23:11:24 -0800
commit3ca88006d9c16e562acf38d2f736486aec93efc5 (patch)
treee681b355f0887bb2fb9de87536df2fa18e1432e4 /meta-python
parent98c3ae0c2e1d5abc48a339b9995b91712abe4c8d (diff)
downloadmeta-openembedded-3ca88006d9c16e562acf38d2f736486aec93efc5.tar.gz
python3-pdm-backend: add recipe
Add pdm-backend, the build backend used by PDM that supports latest packaging standards. Version 2.1.7 provides: - Rename tag-pattern to tag_regex in the docs - Copytree handle existing dirs - Normalize the dist info name in the wheel Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb b/meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb
new file mode 100644
index 0000000000..679ecb0d4a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pdm-backend_2.1.7.bb
@@ -0,0 +1,13 @@
1SUMMARY = "The build backend used by PDM that supports latest packaging standards"
2HOMEPAGE = "https://github.com/pdm-project/pdm-backend"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a564297b3c5b629a528b92fd8ff61ea"
6
7SRC_URI[sha256sum] = "d3b50ab6374557c1edc348135e0da5decef228ddf8c973a58e40f437cf3595ba"
8
9inherit pypi python_setuptools_build_meta
10
11PYPI_PACKAGE= "pdm_backend"
12
13BBCLASSEXTEND = "native nativesdk"