summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorPeter Marko <peter.marko@siemens.com>2025-02-06 20:19:00 +0100
committerKhem Raj <raj.khem@gmail.com>2025-02-06 11:25:02 -0800
commit3fdbefe915dd00ad6c46d324f8f47679d91b8320 (patch)
tree2c4007939d79e9861bdb0b2294a0dc9a5a1bc47e /meta-python
parentbd8570dba0e1cca06c42b69afff4c2d8acbb2a7a (diff)
downloadmeta-openembedded-3fdbefe915dd00ad6c46d324f8f47679d91b8320.tar.gz
python3-grpcio: use system re2
This also allows to remove a custom patch to maintain and corrects license, SPDX and CVE handling. Signed-off-by: Peter Marko <peter.marko@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch29
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb4
2 files changed, 2 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch
deleted file mode 100644
index a2bd294a01..0000000000
--- a/meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 0760579b4890b48ea3ab36e48f1f6fb3e7ed05f5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 30 Jan 2023 10:31:10 -0800
4Subject: [PATCH] Include missing <cstdint> header
5
6gcc 13 moved some includes around and as a result <cstdint> is
7no longer transitively included [1]. Explicitly include it for
8int32_t.
9
10[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
11
12Upstream-Status: Submitted [https://code-review.googlesource.com/c/re2/+/60970]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 third_party/re2/util/pcre.h | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/third_party/re2/util/pcre.h b/third_party/re2/util/pcre.h
19index 896b0bd..271a005 100644
20--- a/third_party/re2/util/pcre.h
21+++ b/third_party/re2/util/pcre.h
22@@ -163,6 +163,7 @@
23
24 #include "util/util.h"
25 #include "re2/stringpiece.h"
26+#include <cstdint>
27
28 #ifdef USEPCRE
29 #include <pcre.h>
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb
index ab615d38e5..f70582ea41 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb
@@ -4,10 +4,9 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0 & BSD-3-Clause" 4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906"
6 6
7DEPENDS += "c-ares openssl python3-protobuf zlib" 7DEPENDS += "c-ares openssl python3-protobuf re2 zlib"
8 8
9SRC_URI += "file://0001-python-enable-unbundled-cross-compilation.patch \ 9SRC_URI += "file://0001-python-enable-unbundled-cross-compilation.patch \
10 file://0001-Include-missing-cstdint-header.patch \
11 file://abseil-ppc-fixes.patch \ 10 file://abseil-ppc-fixes.patch \
12 " 11 "
13SRC_URI[sha256sum] = "936fa44241b5379c5afc344e1260d467bee495747eaf478de825bab2791da6f5" 12SRC_URI[sha256sum] = "936fa44241b5379c5afc344e1260d467bee495747eaf478de825bab2791da6f5"
@@ -21,6 +20,7 @@ CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
21 20
22export GRPC_PYTHON_BUILD_SYSTEM_CARES = "1" 21export GRPC_PYTHON_BUILD_SYSTEM_CARES = "1"
23export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL = "1" 22export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL = "1"
23export GRPC_PYTHON_BUILD_SYSTEM_RE2 = "1"
24export GRPC_PYTHON_BUILD_SYSTEM_ZLIB = "1" 24export GRPC_PYTHON_BUILD_SYSTEM_ZLIB = "1"
25 25
26GRPC_CFLAGS ?= "" 26GRPC_CFLAGS ?= ""