summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:04 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:32 -0800
commit5cb0fc02c16bc50d87d5d754e8635e4e1ed359b0 (patch)
treebcdfed23f0ca61bba38f134734f7d45a10a026e1 /meta-python
parentc96ff70bd6aa8fbf462d4da0603ec667d1967064 (diff)
downloadmeta-openembedded-5cb0fc02c16bc50d87d5d754e8635e4e1ed359b0.tar.gz
python3-iso3166: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-iso3166/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb3
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-iso3166/run-ptest b/meta-python/recipes-devtools/python/python3-iso3166/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-iso3166/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-iso3166/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb b/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb
index b32cfe5956..3aa084d10a 100644
--- a/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb
@@ -12,7 +12,8 @@ SRC_URI += " \
12" 12"
13 13
14RDEPENDS:${PN}-ptest += " \ 14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \ 15 python3-pytest \
16 python3-unittest-automake-output \
16" 17"
17 18
18do_install_ptest() { 19do_install_ptest() {