diff options
author | Derek Straka <derek@asterius.io> | 2025-01-30 21:57:33 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-30 14:15:36 -0800 |
commit | 60a06d274cce46937e8731f1548e149cb4f06ff8 (patch) | |
tree | bd2e1cd8e7569ecc26d83fa2fa6176d9c2719bde /meta-python | |
parent | c43e6a0dbac32f66a2b9d4f45faa077d4ac97417 (diff) | |
download | meta-openembedded-60a06d274cce46937e8731f1548e149cb4f06ff8.tar.gz |
python3-flexcache: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flexcache/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flexcache_0.3.bb | 16 |
2 files changed, 2 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flexcache/run-ptest b/meta-python/recipes-devtools/python/python3-flexcache/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-flexcache/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb index 1bee774022..35769b45c4 100644 --- a/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb +++ b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb | |||
@@ -5,22 +5,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144" | |||
5 | DEPENDS += "python3-setuptools-scm-native" | 5 | DEPENDS += "python3-setuptools-scm-native" |
6 | SRC_URI[sha256sum] = "18743bd5a0621bfe2cf8d519e4c3bfdf57a269c15d1ced3fb4b64e0ff4600656" | 6 | SRC_URI[sha256sum] = "18743bd5a0621bfe2cf8d519e4c3bfdf57a269c15d1ced3fb4b64e0ff4600656" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta ptest | 8 | inherit pypi python_setuptools_build_meta ptest-python-pytest |
9 | PYPI_PACKAGE = "flexcache" | 9 | PYPI_PACKAGE = "flexcache" |
10 | 10 | ||
11 | SRC_URI += " \ | 11 | PTEST_PYTEST_DIR = "flexcache/testsuite" |
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | RDEPENDS:${PN}-ptest += " \ | ||
16 | python3-pytest \ | ||
17 | python3-unittest-automake-output \ | ||
18 | " | ||
19 | |||
20 | do_install_ptest() { | ||
21 | install -d ${D}${PTEST_PATH}/testsuite | ||
22 | cp -rf ${S}/flexcache/testsuite/* ${D}${PTEST_PATH}/testsuite/ | ||
23 | } | ||
24 | 12 | ||
25 | RDEPENDS:${PN} += " \ | 13 | RDEPENDS:${PN} += " \ |
26 | python3-compression \ | 14 | python3-compression \ |