summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-03-01 16:44:46 -0500
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:48:07 -0800
commit689a4a54febba1fd712259cc235dd02e6687cdc5 (patch)
tree84253795e588350ab2a4bf5b13749da05e07a9f9 /meta-python
parentc340e94cd062f3d2cace451096b58e34b4f072d1 (diff)
downloadmeta-openembedded-689a4a54febba1fd712259cc235dd02e6687cdc5.tar.gz
python3-ntplib: pull from PyPI
Switch back to pulling from PyPI which now does have appropriate release tarballs. This fixes building the wheel. While touching the recipe, also add HOMEPAGE and point LIC_FILES_CHKSUM at the LICENSE file that's now part of the release tarball. Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ntplib_0.4.0.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ntplib_0.4.0.bb b/meta-python/recipes-devtools/python/python3-ntplib_0.4.0.bb
index e8620b14b5..d78bec046f 100644
--- a/meta-python/recipes-devtools/python/python3-ntplib_0.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ntplib_0.4.0.bb
@@ -1,13 +1,11 @@
1DESCRIPTION = "This module offers a simple interface to query NTP servers from Python." 1DESCRIPTION = "This module offers a simple interface to query NTP servers from Python."
2HOMEPAGE = "https://github.com/cf-natali/ntplib"
2SECTION = "devel/python" 3SECTION = "devel/python"
3LICENSE = "MIT" 4LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://ntplib.py;beginline=1;endline=23;md5=afa07338a9595257e94c205c3e72224d" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=40707636fe237d725e2bd32cd949b7fe"
5 6
6SRC_URI = "git://github.com/cf-natali/ntplib.git;branch=master;protocol=https" 7SRC_URI[sha256sum] = "899d8fb5f8c2555213aea95efca02934c7343df6ace9d7628a5176b176906267"
7SRCREV ?= "b9c11c5906bc802a20a2dab390e57c50be558808"
8 8
9S = "${WORKDIR}/git" 9inherit pypi setuptools3
10
11inherit setuptools3 python3native
12 10
13RDEPENDS:${PN} += "${PYTHON_PN}-datetime ${PYTHON_PN}-io" 11RDEPENDS:${PN} += "${PYTHON_PN}-datetime ${PYTHON_PN}-io"