summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-11-20 22:23:00 -0800
committerKhem Raj <raj.khem@gmail.com>2024-11-21 21:42:35 -0800
commit6abdc6faa35b0ac89983dccc57e291e58c6d94e8 (patch)
tree9ca3a125a9bd322d08c1563cfa06fe3953a632ea /meta-python
parent6294b31374c03d15761c430fae470a886d08da97 (diff)
downloadmeta-openembedded-6abdc6faa35b0ac89983dccc57e291e58c6d94e8.tar.gz
python3-black: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-black_24.10.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-black_24.10.0.bb b/meta-python/recipes-devtools/python/python3-black_24.10.0.bb
new file mode 100644
index 0000000000..612a2a5ab3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-black_24.10.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "The uncompromising code formatter."
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=d3465a2a183908c9cb95bf490bd1e7ab \
4 file://docs/license.md;md5=d826b3c5269f21a8a0272af3f00d15c0 \
5 file://src/blib2to3/LICENSE;md5=bbbad7490e921f9a73c0e891305cb4b3"
6
7DEPENDS = "python3-hatch-vcs-native python3-hatchling-native"
8SRC_URI[sha256sum] = "846ea64c97afe3bc677b761787993be4991810ecc7a4a937816dd6bddedc4875"
9
10inherit pypi python_hatchling
11
12DEPENDS += "python3-hatch-fancy-pypi-readme-native"
13
14PYPI_PACKAGE = "black"
15
16RDEPENDS:${PN} = "python3-click \
17 python3-mypy-extensions \
18 python3-packaging \
19 python3-pathspec \
20 python3-platformdirs \
21 python3-tomli \
22 python3-typing-extensions \
23 "