diff options
author | alperak <alperyasinak1@gmail.com> | 2024-10-11 16:04:37 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-10-11 07:52:22 -0700 |
commit | 6f49be3368a7af12a60e78b660114880c6db89dc (patch) | |
tree | 7dc3a656d02e701c9b12c72e23d96475c0edb870 /meta-python | |
parent | de34d6fefadf1a67a33241a8950a95709a522c32 (diff) | |
download | meta-openembedded-6f49be3368a7af12a60e78b660114880c6db89dc.tar.gz |
python3-propcache: enable ptest
- Tested on qemux86-64 and qemuarm64
- Added ptest to PTESTS_FAST_META_PYTHON
Ptest result:
=============
qemux86-64:
Testsuite summary
TOTAL: 37
PASS: 37
SKIP: 0
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 7
END: /usr/lib/python3-propcache/ptest
2024-10-11T08:21
STOP: ptest-runner
TOTAL: 1 FAIL: 0
qemuarm64:
Testsuite summary
TOTAL: 37
PASS: 37
SKIP: 0
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 6
END: /usr/lib/python3-propcache/ptest
2024-10-11T08:16
STOP: ptest-runner
TOTAL: 1 FAIL: 0
Signed-off-by: alperak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 22 insertions, 3 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc index da6206c6ba..25d71a2b6f 100644 --- a/meta-python/conf/include/ptest-packagelists-meta-python.inc +++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc | |||
@@ -49,6 +49,7 @@ PTESTS_FAST_META_PYTHON = "\ | |||
49 | python3-portalocker \ | 49 | python3-portalocker \ |
50 | python3-precise-runner \ | 50 | python3-precise-runner \ |
51 | python3-prettytable \ | 51 | python3-prettytable \ |
52 | python3-propcache \ | ||
52 | python3-pydantic \ | 53 | python3-pydantic \ |
53 | python3-pydantic-core \ | 54 | python3-pydantic-core \ |
54 | python3-pylint \ | 55 | python3-pylint \ |
diff --git a/meta-python/recipes-devtools/python/python3-propcache/run-ptest b/meta-python/recipes-devtools/python/python3-propcache/run-ptest new file mode 100644 index 0000000000..8d2017d39c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-propcache/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb b/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb index 874c9fd8ee..5f9fbda5f1 100644 --- a/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb +++ b/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb | |||
@@ -5,9 +5,24 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "df81779732feb9d01e5d513fad0122efb3d53bbc75f61b2a4f29a020bc985e70" | 6 | SRC_URI[sha256sum] = "df81779732feb9d01e5d513fad0122efb3d53bbc75f61b2a4f29a020bc985e70" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta | 8 | inherit pypi python_setuptools_build_meta ptest |
9 | |||
10 | SRC_URI += " \ | ||
11 | file://run-ptest \ | ||
12 | " | ||
9 | 13 | ||
10 | DEPENDS += " \ | 14 | DEPENDS += " \ |
11 | python3-expandvars-native \ | 15 | python3-expandvars-native \ |
12 | python3-cython-native \ | 16 | python3-cython-native \ |
13 | " | 17 | " |
18 | |||
19 | RDEPENDS:${PN}-ptest = " \ | ||
20 | python3-pytest \ | ||
21 | python3-pytest-xdist \ | ||
22 | python3-unittest-automake-output \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/tests | ||
27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
28 | } | ||