summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 17:56:59 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit90ca842c7a4f08e66cc3d1eb11fc0b3a1129526a (patch)
treeef70c34859f9eb6b6b1314f2c136ad94e356b3a9 /meta-python
parentd5df1fe869a9a746438a6ad8c208a170357e7e5a (diff)
downloadmeta-openembedded-90ca842c7a4f08e66cc3d1eb11fc0b3a1129526a.tar.gz
python3-cmd2: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cmd2.inc13
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb20
2 files changed, 16 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-cmd2.inc b/meta-python/recipes-devtools/python/python-cmd2.inc
deleted file mode 100644
index 68381ad220..0000000000
--- a/meta-python/recipes-devtools/python/python-cmd2.inc
+++ /dev/null
@@ -1,13 +0,0 @@
1SUMMARY = "Extra features for standard library's cmd module"
2HOMEPAGE = "http://packages.python.org/cmd2/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def"
5
6SRC_URI[md5sum] = "6db66a06210d5f1edb44693b887ed62b"
7SRC_URI[sha256sum] = "8ad12ef3cc46d03073c545b6e80a3f84a5921f6653073a60e7d9a7ff3b352c9e"
8
9inherit pypi
10
11DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
12
13BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb b/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
index f5c5c7e1a3..a2bf0c45e2 100644
--- a/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
+++ b/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
@@ -1,9 +1,21 @@
1inherit setuptools3 1SUMMARY = "Extra features for standard library's cmd module"
2require python-cmd2.inc 2HOMEPAGE = "http://packages.python.org/cmd2/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def"
5
6DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
7
8SRC_URI[md5sum] = "6db66a06210d5f1edb44693b887ed62b"
9SRC_URI[sha256sum] = "8ad12ef3cc46d03073c545b6e80a3f84a5921f6653073a60e7d9a7ff3b352c9e"
10
11inherit pypi setuptools3
3 12
4RDEPENDS_${PN} += "\ 13RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-colorama \
5 ${PYTHON_PN}-pyperclip \ 16 ${PYTHON_PN}-pyperclip \
6 ${PYTHON_PN}-colorama \ 17 ${PYTHON_PN}-colorama \
7 ${PYTHON_PN}-attrs \
8 ${PYTHON_PN}-wcwidth \ 18 ${PYTHON_PN}-wcwidth \
9 " 19"
20
21BBCLASSEXTEND = "native nativesdk"