summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-10-14 20:08:07 -0700
committerKhem Raj <raj.khem@gmail.com>2024-10-14 20:10:02 -0700
commit98b7cb5dd341e90491e68c882a6fb22ed3e2436e (patch)
tree4cab7f6f328754416479b92571ff8e0d570f6279 /meta-python
parentfdb98927cf69dbb8b3d800c955da17268f3df56a (diff)
downloadmeta-openembedded-98b7cb5dd341e90491e68c882a6fb22ed3e2436e.tar.gz
python3-pytest-codspeed: Add recipe
Needed by yarl ptests Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-codspeed_2.2.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-codspeed_2.2.1.bb b/meta-python/recipes-devtools/python/python3-pytest-codspeed_2.2.1.bb
new file mode 100644
index 0000000000..b7b5461f6b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-codspeed_2.2.1.bb
@@ -0,0 +1,12 @@
1SUMMARY = "Pytest plugin to create CodSpeed benchmarks"
2HOMEPAGE = "https://codspeed.io/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=2856cbe664e8843cd4fd4c1d1d85c2c3"
5
6DEPENDS = "python3-hatchling-native"
7SRC_URI[sha256sum] = "0adc24baf01c64a6ca0a0b83b3cd704351708997e09ec086b7776c32227d4e0a"
8
9inherit pypi python_hatchling
10
11PYPI_PACKAGE = "pytest_codspeed"
12RDEPENDS:${PN} = "python3-cffi python3-filelock python3-pytest"