summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-10 20:57:27 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-10 16:53:46 -0800
commit9bcd41e7b08fbcf59f7679e05a03f911cadcafd4 (patch)
treec031ab5052afec5dfe075baf6536cd8d456699fc /meta-python
parent5f737ede0e7e0a248b11c197a5f9f7bf1f72f90e (diff)
downloadmeta-openembedded-9bcd41e7b08fbcf59f7679e05a03f911cadcafd4.tar.gz
python3-tomlkit: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit_0.13.2.bb13
2 files changed, 1 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest b/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.13.2.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.13.2.bb
index 9fca145407..8eeb9d7603 100644
--- a/meta-python/recipes-devtools/python/python3-tomlkit_0.13.2.bb
+++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.13.2.bb
@@ -5,11 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82"
5 5
6SRC_URI[sha256sum] = "fff5fe59a87295b278abd31bec92c15d9bc4a06885ab12bcea52c71119392e79" 6SRC_URI[sha256sum] = "fff5fe59a87295b278abd31bec92c15d9bc4a06885ab12bcea52c71119392e79"
7 7
8inherit pypi python_poetry_core ptest 8inherit pypi python_poetry_core ptest-python-pytest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13 9
14RDEPENDS:${PN} += " \ 10RDEPENDS:${PN} += " \
15 python3-datetime \ 11 python3-datetime \
@@ -19,14 +15,7 @@ RDEPENDS:${PN} += " \
19 15
20RDEPENDS:${PN}-ptest += " \ 16RDEPENDS:${PN}-ptest += " \
21 python3-poetry-core \ 17 python3-poetry-core \
22 python3-pytest \
23 python3-pyyaml \ 18 python3-pyyaml \
24 python3-unittest-automake-output \
25" 19"
26 20
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
32BBCLASSEXTEND = "native nativesdk" 21BBCLASSEXTEND = "native nativesdk"