summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-08-07 14:35:13 +0300
committerKhem Raj <raj.khem@gmail.com>2024-08-09 14:25:23 -0700
commitb14f6fedf4dd76e178184e9fff206c9d554450e0 (patch)
tree4d9ad58855b58ee76b30aa1c954997d7a6cb2ffb /meta-python
parentb5512cead2d7b57196386b2050a1777458ba783d (diff)
downloadmeta-openembedded-b14f6fedf4dd76e178184e9fff206c9d554450e0.tar.gz
python3-screeninfo: switch to PEP-517 build backend
The project has a proper pyproject.toml which declares the poetry.core.masonry.api PEP-517 backend. Fix: WARNING: python3-screeninfo-0.8.1-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with poetry.core.masonry.api, use the correct class [pep517-backend] Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb b/meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb
index 19ac3f67f0..a7a20707ef 100644
--- a/meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-screeninfo_0.8.1.bb
@@ -4,11 +4,9 @@ SECTION = "devel/python"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a23813181e06852d377bc25ae5563a97" 5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a23813181e06852d377bc25ae5563a97"
6 6
7PYPI_PACKAGE = "screeninfo"
8
9SRC_URI[sha256sum] = "9983076bcc7e34402a1a9e4d7dabf3729411fd2abb3f3b4be7eba73519cd2ed1" 7SRC_URI[sha256sum] = "9983076bcc7e34402a1a9e4d7dabf3729411fd2abb3f3b4be7eba73519cd2ed1"
10 8
11inherit pypi setuptools3 9inherit pypi python_poetry_core
12 10
13RDEPENDS:${PN} += "\ 11RDEPENDS:${PN} += "\
14 python3-core \ 12 python3-core \