diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-06-22 15:59:30 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-23 10:45:31 -0700 |
commit | b32b4347244b043f442b860550c21f78f34f5e5c (patch) | |
tree | 5f465d4cb7340c45f5d808884c75dc73908b41f9 /meta-python | |
parent | fa2d3338fb87a38a66d11735b876ce2320045b0d (diff) | |
download | meta-openembedded-b32b4347244b043f442b860550c21f78f34f5e5c.tar.gz |
meta-python: Add python3-fastjsonschema and its dependencies
python3-fastjsonschema claims to be fastest Python implementation of JSON schema
it however needs additional packages which are also added here, since
they are all dependent, its added in single commit so backporting is
simpler
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
8 files changed, 140 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb new file mode 100644 index 0000000000..415a430672 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "``aspectlib`` is an aspect-oriented programming, monkey-patch and decorators library. It is useful when changing" | ||
5 | HOMEPAGE = "https://github.com/ionelmc/python-aspectlib" | ||
6 | LICENSE = "BSD-2-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e" | ||
8 | |||
9 | SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS_${PN} += "python3-core python3-fields" | ||
14 | |||
15 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb new file mode 100644 index 0000000000..ec16e8884e --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "execnet: rapid multi-Python deployment" | ||
5 | HOMEPAGE = "https://execnet.readthedocs.io/en/latest/" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e" | ||
8 | |||
9 | SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5" | ||
10 | |||
11 | DEPENDS += "python3-pip-native" | ||
12 | |||
13 | inherit pypi setuptools3 | ||
14 | |||
15 | PACKAGECONFIG[testing] = ",,,python3-pre-commit" | ||
16 | |||
17 | RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" | ||
18 | |||
19 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest b/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest new file mode 100644 index 0000000000..b63c4de0d9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-fastjsonschema_2.15.1.bb b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.15.1.bb new file mode 100644 index 0000000000..d901fcb2e0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.15.1.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Fastest Python implementation of JSON schema" | ||
5 | HOMEPAGE = "https://github.com/seznam/python-fastjsonschema" | ||
6 | LICENSE = "BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532" | ||
8 | |||
9 | SRCREV = "1e214911fe83dbaeea3d50dfb3a539118de8a442" | ||
10 | PYPI_SRC_URI = "git://github.com/horejsek/python-fastjsonschema;protocol=https;branch=master" | ||
11 | |||
12 | SRC_URI += "file://run-ptest" | ||
13 | |||
14 | inherit ptest pypi setuptools3 | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install_ptest() { | ||
19 | install -d ${D}${PTEST_PATH}/tests | ||
20 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
21 | } | ||
22 | |||
23 | RDEPENDS_${PN}-ptest += "\ | ||
24 | python3-colorama \ | ||
25 | python3-jsonschema \ | ||
26 | python3-pylint \ | ||
27 | python3-pytest \ | ||
28 | python3-pytest-benchmark \ | ||
29 | python3-pytest-cache \ | ||
30 | " | ||
31 | RDEPENDS_${PN} += "\ | ||
32 | python3-core \ | ||
33 | python3-urllib3 \ | ||
34 | python3-numbers \ | ||
35 | python3-pickle \ | ||
36 | " | ||
37 | |||
38 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-fields_5.0.0.bb b/meta-python/recipes-devtools/python/python3-fields_5.0.0.bb new file mode 100644 index 0000000000..9c22b920d2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-fields_5.0.0.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Container class boilerplate killer." | ||
5 | HOMEPAGE = "https://github.com/ionelmc/python-fields" | ||
6 | LICENSE = "BSD-2-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e32c6705498713d9c904a9f565953a2c" | ||
8 | |||
9 | SRC_URI[sha256sum] = "31d4aa03d8d44e35df13c431de35136997f047a924a597d84f7bc209e1be5727" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS_${PN} += "python3-core" | ||
14 | |||
15 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb new file mode 100644 index 0000000000..1f81a83230 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Get CPU info with pure Python 2 & 3" | ||
5 | HOMEPAGE = "https://github.com/workhorsy/py-cpuinfo" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b0b97c022f12b14d9e02de0b283ee9e9" | ||
8 | |||
9 | SRC_URI[sha256sum] = "5f269be0e08e33fd959de96b34cd4aeeeacac014dd8305f70eb28d06de2345c5" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS_${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell" | ||
14 | |||
15 | # WARNING: We were unable to map the following python package/module | ||
16 | # dependencies to the bitbake packages which include them: | ||
17 | # _winreg | ||
18 | # cStringIO | ||
19 | # winreg | ||
20 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb b/meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb new file mode 100644 index 0000000000..5fb11ddb7f --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "A ``pytest`` fixture for benchmarking code. It will group the tests into rounds that are calibrated to the chosen timer." | ||
5 | HOMEPAGE = "https://github.com/ionelmc/pytest-benchmark" | ||
6 | LICENSE = "BSD-2-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9c5c2c74370826468065c5702b8a1fcf" | ||
8 | |||
9 | SRC_URI[sha256sum] = "40e263f912de5a81d891619032983557d62a3d85843f9a9f30b98baea0cd7b47" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS_${PN} += "python3-core python3-py-cpuinfo python3-pytest python3-aspectlib" | ||
14 | |||
15 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest-cache_1.0.bb b/meta-python/recipes-devtools/python/python3-pytest-cache_1.0.bb new file mode 100644 index 0000000000..4ce91dd982 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest-cache_1.0.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "pytest plugin with mechanisms for caching across test runs" | ||
5 | HOMEPAGE = "http://bitbucket.org/hpk42/pytest-cache/" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6bb0320b04a0a503f12f69fea479de9" | ||
8 | |||
9 | SRC_URI[sha256sum] = "be7468edd4d3d83f1e844959fd6e3fd28e77a481440a7118d430130ea31b07a9" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS_${PN} += "python3-core python3-execnet python3-pprint python3-py python3-pytest" | ||
14 | |||
15 | BBCLASSEXTEND = "native nativesdk" | ||