summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-10-31 14:41:13 +0100
committerKhem Raj <raj.khem@gmail.com>2024-10-31 08:13:26 -0700
commitb8ce4f282ba0e65dfc8e98c84f6cfd26fb53c111 (patch)
tree3282950c66a48df8df354ae6cd9b6eacd15e3c47 /meta-python
parent770a55c38d31410fa946a1582ad5c39b492c7863 (diff)
downloadmeta-openembedded-b8ce4f282ba0e65dfc8e98c84f6cfd26fb53c111.tar.gz
python3-flask-sijax: fold .inc file into .bb
* python2 is long dead, kill .inc file as well Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-sijax.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb17
2 files changed, 15 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-sijax.inc b/meta-python/recipes-devtools/python/python-flask-sijax.inc
deleted file mode 100644
index 239c843fce..0000000000
--- a/meta-python/recipes-devtools/python/python-flask-sijax.inc
+++ /dev/null
@@ -1,12 +0,0 @@
1DESCRIPTION = "An extension for the Flask microframework that adds Sijax support."
2HOMEPAGE = "https://github.com/spantaleev/flask-sijax"
3LICENSE = "BSD-3-Clause"
4
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=266adc7b911b7c84b837bf77196e1ba6"
6
7PYPI_PACKAGE = "Flask-Sijax"
8RDEPENDS:${PN} += " \
9 python3-flask \
10 python3-sijax \
11 python3-werkzeug \
12"
diff --git a/meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb b/meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb
index e9a65c4aef..d518a1877f 100644
--- a/meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb
@@ -1,4 +1,17 @@
1DESCRIPTION = "An extension for the Flask microframework that adds Sijax support."
2HOMEPAGE = "https://github.com/spantaleev/flask-sijax"
3LICENSE = "BSD-3-Clause"
4
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=266adc7b911b7c84b837bf77196e1ba6"
6
7SRC_URI[sha256sum] = "fb2bf2d4f75408185102195055d75549fee8d9c9e954dca2427186925cdc429f"
8
9PYPI_PACKAGE = "Flask-Sijax"
10
1inherit pypi setuptools3 11inherit pypi setuptools3
2require python-flask-sijax.inc
3 12
4SRC_URI[sha256sum] = "fb2bf2d4f75408185102195055d75549fee8d9c9e954dca2427186925cdc429f" \ No newline at end of file 13RDEPENDS:${PN} += " \
14 python3-flask \
15 python3-sijax \
16 python3-werkzeug \
17"