summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-01 16:32:39 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-01 20:09:08 -0700
commitbb10cde447ebbb80a9ea54a4d07b81f1e99eaeb7 (patch)
tree71f6ca1d73ad3ec2f62a1bd1f99b38be90e7ae7c /meta-python
parent9d5171a8a164fc1c47fdb5a43b7bb1b2d3e7455d (diff)
downloadmeta-openembedded-bb10cde447ebbb80a9ea54a4d07b81f1e99eaeb7.tar.gz
python3-jsbeautifier: add recipe
Add a new recipe for jsbeautifier version 1.14.9, JavaScript unobfuscator and beautifier. This work was sponsored by GOVCERT.LU. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsbeautifier_1.14.9.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsbeautifier_1.14.9.bb b/meta-python/recipes-devtools/python/python3-jsbeautifier_1.14.9.bb
new file mode 100644
index 0000000000..ac3c4319cf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsbeautifier_1.14.9.bb
@@ -0,0 +1,19 @@
1SUMMARY = "JavaScript unobfuscator and beautifier."
2HOMEPAGE = "https://beautifier.io/"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
6
7inherit pypi setuptools3
8
9SRC_URI[sha256sum] = "c738ebc36b47bd94e4ca6dd17a9004c3cc74edad582ca1d60e0e5d5945a63cb9"
10
11PYPI_PACKAGE="jsbeautifier"
12
13RDEPENDS:${PN} += "\
14 ${PYTHON_PN}-core \
15 ${PYTHON_PN}-stringold \
16 ${PYTHON_PN}-shell \
17"
18
19BBCLASSEXTEND = "native nativesdk"