diff options
author | Windel Bouwman <windel.bouwman@gmail.com> | 2019-07-30 07:27:21 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-07-30 19:15:24 -0700 |
commit | bc27c62dced424e9e9f49fa13041f575a0b41fad (patch) | |
tree | 0d83d0f1bbc6a729c1f96aba49c7c4574b59128a /meta-python | |
parent | da6b51b555eeff3edad86fb29ee7d95b6f295372 (diff) | |
download | meta-openembedded-bc27c62dced424e9e9f49fa13041f575a0b41fad.tar.gz |
Add recipe for the coloredlogs python package.
Signed-off-by: Windel Bouwman <windel.bouwman@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-coloredlogs.inc b/meta-python/recipes-devtools/python/python-coloredlogs.inc new file mode 100644 index 0000000000..f43bea1f74 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-coloredlogs.inc | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Colored terminal output for Python's logging module" | ||
2 | HOMEPAGE = "https://coloredlogs.readthedocs.io" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=690da298a43805797a4fa7bbe180b3c6" | ||
6 | |||
7 | SRC_URI[md5sum] = "0a186966a1955fff8cf9489373e691d9" | ||
8 | SRC_URI[sha256sum] = "b869a2dda3fa88154b9dd850e27828d8755bfab5a838a1c97fbc850c6e377c36" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | do_compile_prepend() { | ||
13 | sed -ie "s/find_pth_directory(),/'',/g" setup.py | ||
14 | } | ||
15 | |||
16 | do_install_append() { | ||
17 | rm -rf ${D}${datadir} | ||
18 | } | ||
19 | |||
20 | RDEPENDS_${PN} += "\ | ||
21 | ${PYTHON_PN}-humanfriendly \ | ||
22 | " | ||
23 | |||
24 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python-coloredlogs_10.0.bb b/meta-python/recipes-devtools/python/python-coloredlogs_10.0.bb new file mode 100644 index 0000000000..0fc1b258c0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-coloredlogs_10.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-coloredlogs.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb b/meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb new file mode 100644 index 0000000000..3872399665 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-coloredlogs.inc | ||