diff options
author | Yuan Chao <yuanc.fnst@cn.fujitsu.com> | 2019-09-19 12:23:41 +0900 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-19 00:09:43 -0700 |
commit | bf73812bc9361fd2e7e7ec47a0175e5d0e339d6c (patch) | |
tree | b486fa36c2184b7ed6e9913dbc56ea92482528c0 /meta-python | |
parent | 810f586371e16ba67d5b374670f16317a8550587 (diff) | |
download | meta-openembedded-bf73812bc9361fd2e7e7ec47a0175e5d0e339d6c.tar.gz |
python-packaging: new recipe
Add new recipe python-packaging as it is RDEPEND of python-pytest.
Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-packaging.inc b/meta-python/recipes-devtools/python/python-packaging.inc new file mode 100644 index 0000000000..c32caaa408 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-packaging.inc | |||
@@ -0,0 +1,10 @@ | |||
1 | DESCRIPTION = "Core utilities for Python packages" | ||
2 | HOMEPAGE = "https://github.com/pypa/packaging" | ||
3 | LICENSE = "Apache-2.0 & BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91" | ||
5 | |||
6 | SRC_URI[md5sum] = "867ce70984dc7b89bbbc3cac2a72b171" | ||
7 | SRC_URI[sha256sum] = "28b924174df7a2fa32c1953825ff29c61e2f5e082343165438812f00d3a7fc47" | ||
8 | |||
9 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
10 | RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing" | ||
diff --git a/meta-python/recipes-devtools/python/python-packaging_19.2.bb b/meta-python/recipes-devtools/python/python-packaging_19.2.bb new file mode 100644 index 0000000000..55d0746bb5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-packaging_19.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-packaging.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-packaging_19.2.bb b/meta-python/recipes-devtools/python/python3-packaging_19.2.bb new file mode 100644 index 0000000000..aa20fb26f9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-packaging_19.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-packaging.inc | ||