diff options
author | Slater, Joseph <joe.slater@windriver.com> | 2020-07-31 09:40:01 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-06 10:26:29 -0700 |
commit | bf8ebe03b9548ddf1eefc83df52f34681d28fbe2 (patch) | |
tree | 310738d654d69b1876f70eb6d17f73ac6b2d0411 /meta-python | |
parent | cb2e90d004dd8d8e868de66c128451ca36c59f05 (diff) | |
download | meta-openembedded-bf8ebe03b9548ddf1eefc83df52f34681d28fbe2.tar.gz |
python3-cryptography: fix two tests
Tests depending on the hypothesis module should be skipped
if the module is not available.
Signed-off-by: Joe Slater <joe.slater@windriver.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cryptography/h-test.patch | 10 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cryptography_2.8.bb | 1 |
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch new file mode 100644 index 0000000000..9f07c73803 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch | |||
@@ -0,0 +1,10 @@ | |||
1 | --- a/tests/hypothesis/__init__.py | ||
2 | +++ b/tests/hypothesis/__init__.py | ||
3 | @@ -3,3 +3,7 @@ | ||
4 | # for complete details. | ||
5 | |||
6 | from __future__ import absolute_import, division, print_function | ||
7 | + | ||
8 | +import pytest | ||
9 | +hypothesis = pytest.importorskip("hypothesis") | ||
10 | + | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb index c75dabb974..95e903b290 100644 --- a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb +++ b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb | |||
@@ -11,6 +11,7 @@ SRC_URI[sha256sum] = "3cda1f0ed8747339bbdf71b9f38ca74c7b592f24f65cdb3ab3765e4b02 | |||
11 | 11 | ||
12 | SRC_URI += " \ | 12 | SRC_URI += " \ |
13 | file://run-ptest \ | 13 | file://run-ptest \ |
14 | file://h-test.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | inherit pypi setuptools3 | 17 | inherit pypi setuptools3 |