summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-08-07 15:19:46 +0300
committerKhem Raj <raj.khem@gmail.com>2024-08-09 14:25:24 -0700
commitc1a179323ebea2b3ad8fee6a96dbb1ddb166b39f (patch)
tree7d4a1d37ea8548da39d6576cbd6ec8a897a5bb93 /meta-python
parent12c575b684034caca0b874fe030617888ea3ddf1 (diff)
downloadmeta-openembedded-c1a179323ebea2b3ad8fee6a96dbb1ddb166b39f.tar.gz
python3-dill: switch to PEP-517 build backend
The project has a proper pyproject.toml which declares the setuptools.build.meta PEP-517 backend. Also, there is no need to set PYPI_PACKAGE_EXT as tar.gz because tar.gz is used by default. Fix: WARNING: python3-dill-0.3.8-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with setuptools.build_meta, use the correct class [pep517-backend] Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dill_0.3.8.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dill_0.3.8.bb b/meta-python/recipes-devtools/python/python3-dill_0.3.8.bb
index 04e7f4bfb8..3481ec06bd 100644
--- a/meta-python/recipes-devtools/python/python3-dill_0.3.8.bb
+++ b/meta-python/recipes-devtools/python/python3-dill_0.3.8.bb
@@ -5,9 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a41509b57cc475ed93f8cb1dbbfaeec1"
5 5
6SRC_URI[sha256sum] = "3ebe3c479ad625c4553aca177444d89b486b1d84982eeacded644afc0cf797ca" 6SRC_URI[sha256sum] = "3ebe3c479ad625c4553aca177444d89b486b1d84982eeacded644afc0cf797ca"
7 7
8inherit pypi setuptools3 8inherit pypi python_setuptools_build_meta
9
10PYPI_PACKAGE_EXT = "tar.gz"
11 9
12RDEPENDS:${PN} += "\ 10RDEPENDS:${PN} += "\
13 python3-multiprocessing \ 11 python3-multiprocessing \