summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2024-12-12 20:37:22 +0000
committerKhem Raj <raj.khem@gmail.com>2024-12-12 12:55:12 -0800
commitc89eb13f4eef40cc1e890759279e97f17fae048d (patch)
tree693ec424f24dc61a98a057616997f1023bdb7471 /meta-python
parentb032aa40e6a652b5933a1a0878048df766bef29a (diff)
downloadmeta-openembedded-c89eb13f4eef40cc1e890759279e97f17fae048d.tar.gz
python3-cmake: update to version 3.31.1
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cmake/run-cmake-from-path.patch20
-rw-r--r--meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb (renamed from meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb)5
2 files changed, 13 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cmake/run-cmake-from-path.patch b/meta-python/recipes-devtools/python/python3-cmake/run-cmake-from-path.patch
index d4d2903d5e..7b4190a70f 100644
--- a/meta-python/recipes-devtools/python/python3-cmake/run-cmake-from-path.patch
+++ b/meta-python/recipes-devtools/python/python3-cmake/run-cmake-from-path.patch
@@ -1,13 +1,13 @@
1Upstream-Status: Pending 1Upstream-Status: Pending
2 2
3--- cmake-3.25.2/src/cmake/__init__.py.old 2023-03-10 09:40:43.582315753 +0100 3--- cmake-3.25.2/src/cmake/__init__.py.old 2024-12-12 20:25:48.207389622 +0000
4+++ cmake-3.25.2/src/cmake/__init__.py 2023-03-10 09:41:38.030874047 +0100 4+++ cmake-3.25.2/src/cmake/__init__.py 2024-12-12 20:25:48.207389622 +0000
5@@ -36,7 +36,7 @@ 5@@ -44,7 +44,7 @@
6 6
7 7
8 def _program(name, args): 8 def _program(name: str, args: Iterable[str]) -> int:
9- return subprocess.call([os.path.join(CMAKE_BIN_DIR, name)] + args, close_fds=False) 9- return subprocess.call([os.path.join(CMAKE_BIN_DIR, name), *args], close_fds=False)
10+ return subprocess.call([name] + args, close_fds=False) 10+ return subprocess.call([name] + args, close_fds=False)
11 11
12 12 def _program_exit(name: str, *args: str) -> NoReturn:
13 def cmake(): 13 if sys.platform.startswith("win"):
diff --git a/meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb b/meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb
index a6c3e139b8..5e75246ecf 100644
--- a/meta-python/recipes-devtools/python/python3-cmake_3.28.3.bb
+++ b/meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb
@@ -5,13 +5,13 @@ LIC_FILES_CHKSUM = " \
5 file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5 \ 5 file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5 \
6" 6"
7 7
8DEPENDS = "ninja-native cmake-native python3-scikit-build-native" 8DEPENDS = "ninja-native cmake-native python3-scikit-build-native python3-scikit-build-core-native"
9 9
10PYPI_PACKAGE = "cmake" 10PYPI_PACKAGE = "cmake"
11PYPI_ARCHIVE_NAME_PREFIX = "pypi-" 11PYPI_ARCHIVE_NAME_PREFIX = "pypi-"
12 12
13inherit pypi python_setuptools_build_meta 13inherit pypi python_setuptools_build_meta
14SRC_URI[sha256sum] = "a8092815c739da7d6775c26ec30c2645f0fca9527a29e36a682faec7d39cde89" 14SRC_URI[sha256sum] = "45e09ef6fc5a0d3d4cac11bfee43ba3f9925f301660630d3d1e5457fbe12ecdf"
15 15
16SRC_URI += " \ 16SRC_URI += " \
17 file://CMakeLists.txt \ 17 file://CMakeLists.txt \
@@ -32,6 +32,7 @@ do_install:append () {
32RDEPENDS:${PN} = " \ 32RDEPENDS:${PN} = " \
33 cmake \ 33 cmake \
34 python3-scikit-build \ 34 python3-scikit-build \
35 python3-scikit-build-core \
35" 36"
36 37
37BBCLASSEXTEND = "native nativesdk" 38BBCLASSEXTEND = "native nativesdk"