diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-09-25 14:18:32 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-09-26 06:58:28 -0700 |
commit | cc3c87cade75d576f4056eda35ecc66b66e12f9d (patch) | |
tree | 7d6ee21238d07bae519e5161298f3cbcc87336ed /meta-python | |
parent | 36ec58d0a31e05a3157c7a45dc4835fb37918365 (diff) | |
download | meta-openembedded-cc3c87cade75d576f4056eda35ecc66b66e12f9d.tar.gz |
python3-ujson: Add python misc modules to ptest rdeps
Its needed for
ModuleNotFoundError: No module named 'tracemalloc'
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb | 3 |
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/run-ptest b/meta-python/recipes-devtools/python/python3-ujson/run-ptest index 8d2017d39c..4863c5e5a3 100644 --- a/meta-python/recipes-devtools/python/python3-ujson/run-ptest +++ b/meta-python/recipes-devtools/python/python3-ujson/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest --automake | 3 | FORCE_COLOR=1 pytest --automake --capture=no |
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb index 18ce5cc301..5f4439c4c3 100644 --- a/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb +++ b/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5 | |||
6 | 6 | ||
7 | SRC_URI[sha256sum] = "b3cd8f3c5d8c7738257f1018880444f7b7d9b66232c64649f562d7ba86ad4bc1" | 7 | SRC_URI[sha256sum] = "b3cd8f3c5d8c7738257f1018880444f7b7d9b66232c64649f562d7ba86ad4bc1" |
8 | 8 | ||
9 | inherit pypi ptest setuptools3 | 9 | inherit pypi ptest python_setuptools_build_meta |
10 | 10 | ||
11 | # let OE do the strip operation | 11 | # let OE do the strip operation |
12 | export UJSON_BUILD_NO_STRIP = "1" | 12 | export UJSON_BUILD_NO_STRIP = "1" |
@@ -24,6 +24,7 @@ RDEPENDS:${PN} += "\ | |||
24 | 24 | ||
25 | RDEPENDS:${PN}-ptest += " \ | 25 | RDEPENDS:${PN}-ptest += " \ |
26 | python3-json \ | 26 | python3-json \ |
27 | python3-misc \ | ||
27 | python3-pytest \ | 28 | python3-pytest \ |
28 | python3-pytz \ | 29 | python3-pytz \ |
29 | python3-unittest-automake-output \ | 30 | python3-unittest-automake-output \ |