diff options
author | Zang Ruochen <zangrc.fnst@cn.fujitsu.com> | 2020-06-28 16:45:19 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-29 08:23:18 -0700 |
commit | e14031a776a32ef30c703b4e55e26a5def5c696c (patch) | |
tree | 360de9e9977850b0172155479b9e40d9e2d4c0b9 /meta-python | |
parent | 3a78e76383bcf61633cff53fc6430497af1fe34c (diff) | |
download | meta-openembedded-e14031a776a32ef30c703b4e55e26a5def5c696c.tar.gz |
python3-bcrypt: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-bcrypt/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bcrypt/run-ptest b/meta-python/recipes-devtools/python/python3-bcrypt/run-ptest new file mode 100644 index 0000000000..b63c4de0d9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-bcrypt/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb index 0f2d31f537..3b9cd52f2c 100644 --- a/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb +++ b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.7.bb | |||
@@ -7,7 +7,20 @@ DEPENDS += "${PYTHON_PN}-cffi-native" | |||
7 | SRC_URI[md5sum] = "5d6f93b575ce52470af37a8e7dce76fe" | 7 | SRC_URI[md5sum] = "5d6f93b575ce52470af37a8e7dce76fe" |
8 | SRC_URI[sha256sum] = "0b0069c752ec14172c5f78208f1863d7ad6755a6fae6fe76ec2c80d13be41e42" | 8 | SRC_URI[sha256sum] = "0b0069c752ec14172c5f78208f1863d7ad6755a6fae6fe76ec2c80d13be41e42" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 ptest |
11 | |||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | RDEPENDS_${PN}-ptest += " \ | ||
17 | ${PYTHON_PN}-pytest \ | ||
18 | " | ||
19 | |||
20 | do_install_ptest() { | ||
21 | install -d ${D}${PTEST_PATH}/tests | ||
22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
23 | } | ||
11 | 24 | ||
12 | RDEPENDS_${PN}_class-target += "\ | 25 | RDEPENDS_${PN}_class-target += "\ |
13 | ${PYTHON_PN}-cffi \ | 26 | ${PYTHON_PN}-cffi \ |