summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-30 21:57:28 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-30 14:15:35 -0800
commite37f7788cb4b8517bc52ba9ee8aea6aceb545939 (patch)
treed27d07bd4e4680c439b42d0973b5db21eeb8f4a1 /meta-python
parentcfaeb648d0f6dbee1f58c25402de8f9d72c1e305 (diff)
downloadmeta-openembedded-e37f7788cb4b8517bc52ba9ee8aea6aceb545939.tar.gz
python3-httptools: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-httptools/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb16
2 files changed, 1 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httptools/run-ptest b/meta-python/recipes-devtools/python/python3-httptools/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-httptools/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb b/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb
index 730df90f1e..49f14da206 100644
--- a/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb
+++ b/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb
@@ -3,20 +3,6 @@ HOMEPAGE = "https://github.com/MagicStack/httptools"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0a2d82955bf3facdf04cb882655e840e" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=0a2d82955bf3facdf04cb882655e840e"
5 5
6inherit pypi setuptools3 ptest 6inherit pypi setuptools3 ptest-python-pytest
7 7
8SRC_URI[sha256sum] = "4e93eee4add6493b59a5c514da98c939b244fce4a0d8879cd3f466562f4b7d5c" 8SRC_URI[sha256sum] = "4e93eee4add6493b59a5c514da98c939b244fce4a0d8879cd3f466562f4b7d5c"
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-pytest \
16 python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}