diff options
author | Derek Straka <derek@asterius.io> | 2025-01-30 21:57:28 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-30 14:15:35 -0800 |
commit | e37f7788cb4b8517bc52ba9ee8aea6aceb545939 (patch) | |
tree | d27d07bd4e4680c439b42d0973b5db21eeb8f4a1 /meta-python | |
parent | cfaeb648d0f6dbee1f58c25402de8f9d72c1e305 (diff) | |
download | meta-openembedded-e37f7788cb4b8517bc52ba9ee8aea6aceb545939.tar.gz |
python3-httptools: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-httptools/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb | 16 |
2 files changed, 1 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httptools/run-ptest b/meta-python/recipes-devtools/python/python3-httptools/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-httptools/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb b/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb index 730df90f1e..49f14da206 100644 --- a/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb +++ b/meta-python/recipes-devtools/python/python3-httptools_0.6.4.bb | |||
@@ -3,20 +3,6 @@ HOMEPAGE = "https://github.com/MagicStack/httptools" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0a2d82955bf3facdf04cb882655e840e" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0a2d82955bf3facdf04cb882655e840e" |
5 | 5 | ||
6 | inherit pypi setuptools3 ptest | 6 | inherit pypi setuptools3 ptest-python-pytest |
7 | 7 | ||
8 | SRC_URI[sha256sum] = "4e93eee4add6493b59a5c514da98c939b244fce4a0d8879cd3f466562f4b7d5c" | 8 | SRC_URI[sha256sum] = "4e93eee4add6493b59a5c514da98c939b244fce4a0d8879cd3f466562f4b7d5c" |
9 | |||
10 | SRC_URI += " \ | ||
11 | file://run-ptest \ | ||
12 | " | ||
13 | |||
14 | RDEPENDS:${PN}-ptest += " \ | ||
15 | python3-pytest \ | ||
16 | python3-unittest-automake-output \ | ||
17 | " | ||
18 | |||
19 | do_install_ptest() { | ||
20 | install -d ${D}${PTEST_PATH}/tests | ||
21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
22 | } | ||