summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-configobj/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb16
2 files changed, 2 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configobj/run-ptest b/meta-python/recipes-devtools/python/python3-configobj/run-ptest
deleted file mode 100755
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-configobj/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb b/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb
index d41d71a4ea..bd4764f4de 100644
--- a/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb
+++ b/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb
@@ -5,23 +5,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e2df3cb285297a24cd1097dfe6e96f95"
5 5
6SRC_URI[sha256sum] = "03c881bbf23aa07bccf1b837005975993c4ab4427ba57f959afdd9d1a2386848" 6SRC_URI[sha256sum] = "03c881bbf23aa07bccf1b837005975993c4ab4427ba57f959afdd9d1a2386848"
7 7
8inherit pypi python_setuptools_build_meta ptest 8inherit pypi python_setuptools_build_meta ptest-python-pytest
9 9
10SRC_URI += " \ 10PTEST_PYTEST_DIR = "src/tests"
11 file://run-ptest \
12"
13 11
14RDEPENDS:${PN} += " \ 12RDEPENDS:${PN} += " \
15 python3-pprint \ 13 python3-pprint \
16 python3-six \ 14 python3-six \
17" 15"
18
19RDEPENDS:${PN}-ptest += " \
20 python3-pytest \
21 python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/src/tests/* ${D}${PTEST_PATH}/tests/
27}