summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-attrs.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb18
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-attrs.inc b/meta-python/recipes-devtools/python/python-attrs.inc
deleted file mode 100644
index 35d28a44d0..0000000000
--- a/meta-python/recipes-devtools/python/python-attrs.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "Classes Without Boilerplate"
2HOMEPAGE = "http://www.attrs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff"
5
6SRC_URI[sha256sum] = "f7b7ce16570fe9965acd6d30101a28f62fb4a7f9e926b3bbc9b61f8b04247e72"
7SRC_URI[md5sum] = "5b2db50fcc31be34d32798183c9bd062"
8
9inherit pypi
10
11RDEPENDS_${PN}_class-target += " \
12 ${PYTHON_PN}-crypt \
13 ${PYTHON_PN}-ctypes \
14"
15
16BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
index c34693f506..b3739fda8c 100644
--- a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
@@ -1,2 +1,16 @@
1inherit setuptools3 1DESCRIPTION = "Classes Without Boilerplate"
2require python-attrs.inc 2HOMEPAGE = "http://www.attrs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff"
5
6SRC_URI[sha256sum] = "f7b7ce16570fe9965acd6d30101a28f62fb4a7f9e926b3bbc9b61f8b04247e72"
7SRC_URI[md5sum] = "5b2db50fcc31be34d32798183c9bd062"
8
9inherit pypi setuptools3
10
11RDEPENDS_${PN}_class-target += " \
12 ${PYTHON_PN}-crypt \
13 ${PYTHON_PN}-ctypes \
14"
15
16BBCLASSEXTEND = "native"