summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
index 1ffb79da71..8cef391bd7 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
@@ -5,32 +5,26 @@ all of its internal RPC protocols and file formats."
5HOMEPAGE = "https://github.com/google/protobuf" 5HOMEPAGE = "https://github.com/google/protobuf"
6SECTION = "console/tools" 6SECTION = "console/tools"
7LICENSE = "BSD-3-Clause" 7LICENSE = "BSD-3-Clause"
8 8LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
9PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
10 9
11DEPENDS = "zlib" 10DEPENDS = "zlib"
12DEPENDS_append_class-target = " protobuf-native" 11DEPENDS_append_class-target = " protobuf-native"
13RDEPENDS_${PN}-compiler = "${PN}"
14RDEPENDS_${PN}-dev += "${PN}-compiler"
15RDEPENDS_${PN}-ptest = "bash python-protobuf"
16
17LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
18 12
13PV .= "+git${SRCPV}"
19SRCREV = "106ffc04be1abf3ff3399f54ccf149815b287dd9" 14SRCREV = "106ffc04be1abf3ff3399f54ccf149815b287dd9"
20 15
21PV = "3.5.1+git${SRCPV}"
22
23SRC_URI = "git://github.com/google/protobuf.git;branch=3.5.x \ 16SRC_URI = "git://github.com/google/protobuf.git;branch=3.5.x \
24 file://run-ptest \ 17 file://run-ptest \
25 " 18"
26 19
27EXTRA_OECONF += " --with-protoc=echo" 20S = "${WORKDIR}/git"
28 21
29inherit autotools-brokensep pkgconfig ptest 22inherit autotools-brokensep pkgconfig ptest
30 23
31S = "${WORKDIR}/git" 24EXTRA_OECONF += "--with-protoc=echo"
32TEST_SRC_DIR="examples" 25
33LANG_SUPPORT="cpp python" 26TEST_SRC_DIR = "examples"
27LANG_SUPPORT = "cpp python"
34 28
35do_compile_ptest() { 29do_compile_ptest() {
36 # Modify makefile to use the cross-compiler 30 # Modify makefile to use the cross-compiler
@@ -76,8 +70,14 @@ do_install_ptest() {
76 cd "$olddir" 70 cd "$olddir"
77} 71}
78 72
73PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
74
79FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}" 75FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}"
80FILES_${PN}-lite = "${bindir} ${libdir}/libprotobuf-lite${SOLIBS}" 76FILES_${PN}-lite = "${libdir}/libprotobuf-lite${SOLIBS}"
77
78RDEPENDS_${PN}-compiler = "${PN}"
79RDEPENDS_${PN}-dev += "${PN}-compiler"
80RDEPENDS_${PN}-ptest = "bash python-protobuf"
81 81
82MIPS_INSTRUCTION_SET = "mips" 82MIPS_INSTRUCTION_SET = "mips"
83 83