diff options
-rw-r--r-- | meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-support/ne10/ne10_1.2.1.bb | 3 |
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch b/meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch new file mode 100644 index 0000000000..a8fea82dc3 --- /dev/null +++ b/meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 66d332e4b631eef800c6f62cd347b164ee3b59d4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 19 Apr 2017 10:11:21 -0700 | ||
4 | Subject: [PATCH] Dont specify -march explicitly | ||
5 | |||
6 | it assumes armv7-a for all armv7 based machines but that may | ||
7 | not be true e.g. machines based on armv7ve and cortexa-7 | ||
8 | it causes conflicts in OE builds because it specifies -march | ||
9 | in recipes anyway so this is redundant in CMakeLists.txt | ||
10 | |||
11 | Fixes | ||
12 | |||
13 | | cc1: warning: switch -mcpu=cortex-a7 conflicts with -march=armv7-a switch | ||
14 | | cc1: warning: switch -mcpu=cortex-a7 conflicts with -march=armv7-a switch | ||
15 | |||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | CMakeLists.txt | 4 ++-- | ||
19 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
20 | |||
21 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
22 | index 68da920..a4b94b9 100644 | ||
23 | --- a/CMakeLists.txt | ||
24 | +++ b/CMakeLists.txt | ||
25 | @@ -138,8 +138,8 @@ if(ANDROID_PLATFORM) | ||
26 | ${CMAKE_C_FLAGS}") | ||
27 | elseif(GNULINUX_PLATFORM) | ||
28 | if("${NE10_TARGET_ARCH}" STREQUAL "armv7") | ||
29 | - set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb -march=armv7-a -mfpu=vfp3 -funsafe-math-optimizations") | ||
30 | - set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -mthumb -march=armv7-a -mfpu=neon") | ||
31 | + set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb -mfpu=vfp3 -funsafe-math-optimizations") | ||
32 | + set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -mthumb -mfpu=neon") | ||
33 | # Turn on asm optimization for Linux on ARM v7. | ||
34 | set(NE10_ASM_OPTIMIZATION on) | ||
35 | endif() | ||
36 | -- | ||
37 | 2.12.2 | ||
38 | |||
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb index 951086f775..e5b50ce755 100644 --- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb +++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb | |||
@@ -6,7 +6,8 @@ SECTION = "libs" | |||
6 | 6 | ||
7 | SRC_URI = "git://github.com/projectNe10/Ne10.git \ | 7 | SRC_URI = "git://github.com/projectNe10/Ne10.git \ |
8 | file://0001-CMakeLists.txt-Remove-mthumb-interwork.patch \ | 8 | file://0001-CMakeLists.txt-Remove-mthumb-interwork.patch \ |
9 | " | 9 | file://0001-Dont-specify-march-explicitly.patch \ |
10 | " | ||
10 | SRCREV = "18c4c982a595dad069cd8df4932aefb1d257591f" | 11 | SRCREV = "18c4c982a595dad069cd8df4932aefb1d257591f" |
11 | 12 | ||
12 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |