summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/upm/upm/0001-include-sys-types.h-for-uint-definition.patch33
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb11
2 files changed, 38 insertions, 6 deletions
diff --git a/meta-oe/recipes-extended/upm/upm/0001-include-sys-types.h-for-uint-definition.patch b/meta-oe/recipes-extended/upm/upm/0001-include-sys-types.h-for-uint-definition.patch
new file mode 100644
index 0000000000..a0a47411d7
--- /dev/null
+++ b/meta-oe/recipes-extended/upm/upm/0001-include-sys-types.h-for-uint-definition.patch
@@ -0,0 +1,33 @@
1From 48a580bd402cf6a3ee9e42013653219bfeb3caf6 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 21 Jun 2018 18:39:16 -0700
4Subject: [PATCH] include sys/types.h for uint definition
5
6uint is defined in sys/types.h, therefore this
7header needs to be included, it gets exposed with
8musl where this header is not getting included indirectly
9as it is happening when building on glibc
10
11Fixes build errors on musl e.g.
12upm/src/kx122/kx122.hpp:456:31: error: 'uint' has not been declared
13| void setBufferThreshold(uint samples);
14| ^~~~
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18Upstream-Status: Submitted [https://github.com/intel-iot-devkit/upm/pull/656]
19 src/kx122/kx122.h | 1 +
20 1 file changed, 1 insertion(+)
21
22diff --git a/src/kx122/kx122.h b/src/kx122/kx122.h
23index 1622ed50..56e5215e 100644
24--- a/src/kx122/kx122.h
25+++ b/src/kx122/kx122.h
26@@ -31,6 +31,7 @@ extern "C"{
27 #include <assert.h>
28 #include <unistd.h>
29 #include <math.h>
30+#include <sys/types.h>
31
32 #include <mraa/i2c.h>
33 #include <mraa/spi.h>
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
index 478aa0db1d..babe5f4893 100644
--- a/meta-oe/recipes-extended/upm/upm_git.bb
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -7,13 +7,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=66493d54e65bfc12c7983ff2e884f37f"
7 7
8DEPENDS = "libjpeg-turbo mraa" 8DEPENDS = "libjpeg-turbo mraa"
9 9
10SRCREV = "37642f3b0194f6ddd63f1e6b5d49b8cb689d5c81" 10SRCREV = "dc45cd78595c7c24c8a8574c63bb48b5bb99c5aa"
11PV = "1.6.0-git${SRCPV}" 11PV = "1.6.0-git${SRCPV}"
12 12
13SRC_URI = " \ 13SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \
14 git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \ 14 file://0001-Replace-strncpy-with-memcpy.patch \
15 file://0001-Replace-strncpy-with-memcpy.patch \ 15 file://0001-include-sys-types.h-for-uint-definition.patch \
16" 16 "
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
@@ -22,7 +22,6 @@ COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64.*|arm.*)-linux"
22 22
23inherit distutils3-base cmake 23inherit distutils3-base cmake
24 24
25
26# override this in local.conf to get needed bindings. 25# override this in local.conf to get needed bindings.
27# BINDINGS_pn-upm="python" 26# BINDINGS_pn-upm="python"
28# will result in only the python bindings being built/packaged. 27# will result in only the python bindings being built/packaged.