diff options
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb.inc | 1 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch | 95 |
2 files changed, 96 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mariadb.inc b/meta-oe/recipes-dbs/mysql/mariadb.inc index 4e285aea7e..1a47d91105 100644 --- a/meta-oe/recipes-dbs/mysql/mariadb.inc +++ b/meta-oe/recipes-dbs/mysql/mariadb.inc | |||
@@ -22,6 +22,7 @@ SRC_URI = "https://archive.mariadb.org/${BP}/source/${BP}.tar.gz \ | |||
22 | file://cross-compiling.patch \ | 22 | file://cross-compiling.patch \ |
23 | file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \ | 23 | file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \ |
24 | file://lfs64.patch \ | 24 | file://lfs64.patch \ |
25 | file://0001-Add-missing-includes-cstdint-and-cstdio.patch \ | ||
25 | " | 26 | " |
26 | SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch" | 27 | SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch" |
27 | SRC_URI[sha256sum] = "ffacf84e74daf249ad64b9573d79a4e882f66b004614f8b33bfcb14a8e25da1d" | 28 | SRC_URI[sha256sum] = "ffacf84e74daf249ad64b9573d79a4e882f66b004614f8b33bfcb14a8e25da1d" |
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch new file mode 100644 index 0000000000..7c37fef493 --- /dev/null +++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch | |||
@@ -0,0 +1,95 @@ | |||
1 | From 6e376601c990abaa5e261d1311f92acb3b370b8f Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 24 Jan 2023 21:40:43 -0800 | ||
4 | Subject: [PATCH] Add missing includes <cstdint> and <cstdio> | ||
5 | |||
6 | This is needed with GCC 13 and newer [1] | ||
7 | |||
8 | [1] https://www.gnu.org/software/gcc/gcc-13/porting_to.html | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | .../rocksdb/rocksdb/db/compaction/compaction_iteration_stats.h | 1 + | ||
14 | storage/rocksdb/rocksdb/include/rocksdb/utilities/checkpoint.h | 1 + | ||
15 | .../rocksdb/rocksdb/table/block_based/data_block_hash_index.h | 1 + | ||
16 | storage/rocksdb/rocksdb/util/slice.cc | 1 + | ||
17 | storage/rocksdb/rocksdb/util/string_util.h | 1 + | ||
18 | tpool/aio_linux.cc | 1 + | ||
19 | 6 files changed, 6 insertions(+) | ||
20 | |||
21 | diff --git a/storage/rocksdb/rocksdb/db/compaction/compaction_iteration_stats.h b/storage/rocksdb/rocksdb/db/compaction/compaction_iteration_stats.h | ||
22 | index 963c1d8eb49..73487edd96d 100644 | ||
23 | --- a/storage/rocksdb/rocksdb/db/compaction/compaction_iteration_stats.h | ||
24 | +++ b/storage/rocksdb/rocksdb/db/compaction/compaction_iteration_stats.h | ||
25 | @@ -5,6 +5,7 @@ | ||
26 | |||
27 | #pragma once | ||
28 | |||
29 | +#include <cstdint> | ||
30 | #include "rocksdb/rocksdb_namespace.h" | ||
31 | |||
32 | struct CompactionIterationStats { | ||
33 | diff --git a/storage/rocksdb/rocksdb/include/rocksdb/utilities/checkpoint.h b/storage/rocksdb/rocksdb/include/rocksdb/utilities/checkpoint.h | ||
34 | index c7f93b4cfcd..3c2ab80535a 100644 | ||
35 | --- a/storage/rocksdb/rocksdb/include/rocksdb/utilities/checkpoint.h | ||
36 | +++ b/storage/rocksdb/rocksdb/include/rocksdb/utilities/checkpoint.h | ||
37 | @@ -8,6 +8,7 @@ | ||
38 | #pragma once | ||
39 | #ifndef ROCKSDB_LITE | ||
40 | |||
41 | +#include <cstdint> | ||
42 | #include <string> | ||
43 | #include <vector> | ||
44 | #include "rocksdb/status.h" | ||
45 | diff --git a/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h b/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h | ||
46 | index f356395f329..3215221755d 100644 | ||
47 | --- a/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h | ||
48 | +++ b/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h | ||
49 | @@ -5,6 +5,7 @@ | ||
50 | |||
51 | #pragma once | ||
52 | |||
53 | +#include <cstdint> | ||
54 | #include <string> | ||
55 | #include <vector> | ||
56 | |||
57 | diff --git a/storage/rocksdb/rocksdb/util/slice.cc b/storage/rocksdb/rocksdb/util/slice.cc | ||
58 | index 6db11cc947a..c26b6a21a57 100644 | ||
59 | --- a/storage/rocksdb/rocksdb/util/slice.cc | ||
60 | +++ b/storage/rocksdb/rocksdb/util/slice.cc | ||
61 | @@ -8,6 +8,7 @@ | ||
62 | // found in the LICENSE file. See the AUTHORS file for names of contributors. | ||
63 | |||
64 | #include <algorithm> | ||
65 | +#include <cstdint> | ||
66 | #include "rocksdb/slice_transform.h" | ||
67 | #include "rocksdb/slice.h" | ||
68 | #include "util/string_util.h" | ||
69 | diff --git a/storage/rocksdb/rocksdb/util/string_util.h b/storage/rocksdb/rocksdb/util/string_util.h | ||
70 | index a761be66c52..064d059f08f 100644 | ||
71 | --- a/storage/rocksdb/rocksdb/util/string_util.h | ||
72 | +++ b/storage/rocksdb/rocksdb/util/string_util.h | ||
73 | @@ -6,6 +6,7 @@ | ||
74 | |||
75 | #pragma once | ||
76 | |||
77 | +#include <cstdint> | ||
78 | #include <sstream> | ||
79 | #include <string> | ||
80 | #include <unordered_map> | ||
81 | diff --git a/tpool/aio_linux.cc b/tpool/aio_linux.cc | ||
82 | index 10234e0e46a..a6adf1af257 100644 | ||
83 | --- a/tpool/aio_linux.cc | ||
84 | +++ b/tpool/aio_linux.cc | ||
85 | @@ -18,6 +18,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02111 - 1301 USA*/ | ||
86 | |||
87 | # include <thread> | ||
88 | # include <atomic> | ||
89 | +# include <cstdio> | ||
90 | # include <libaio.h> | ||
91 | # include <sys/syscall.h> | ||
92 | |||
93 | -- | ||
94 | 2.39.1 | ||
95 | |||