diff options
-rw-r--r-- | meta-oe/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-support/postgresql/postgresql.inc | 1 |
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch b/meta-oe/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch new file mode 100644 index 0000000000..d08ec6af1d --- /dev/null +++ b/meta-oe/recipes-support/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From d52e330be895bb8c5f0fb3e2884766acbd942a85 Mon Sep 17 00:00:00 2001 | ||
2 | From: Philip Balister <philip@balister.org> | ||
3 | Date: Tue, 1 Jul 2014 09:40:44 -0400 | ||
4 | Subject: [PATCH] Use pkg-config for libxml2 detection. | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | xml2-config does not work. Use pkgconfig to set CPPFLAGS and LIBS. | ||
9 | |||
10 | Signed-off-by: Philip Balister <philip@balister.org> | ||
11 | --- | ||
12 | configure.in | 15 ++------------- | ||
13 | 1 file changed, 2 insertions(+), 13 deletions(-) | ||
14 | |||
15 | diff --git a/configure.in b/configure.in | ||
16 | index f8bf466..1f4fabf 100644 | ||
17 | --- a/configure.in | ||
18 | +++ b/configure.in | ||
19 | @@ -734,19 +734,8 @@ PGAC_ARG_BOOL(with, libxml, no, [build with XML support], | ||
20 | [AC_DEFINE([USE_LIBXML], 1, [Define to 1 to build with XML support. (--with-libxml)])]) | ||
21 | |||
22 | if test "$with_libxml" = yes ; then | ||
23 | - AC_CHECK_PROGS(XML2_CONFIG, xml2-config) | ||
24 | - if test -n "$XML2_CONFIG"; then | ||
25 | - for pgac_option in `$XML2_CONFIG --cflags`; do | ||
26 | - case $pgac_option in | ||
27 | - -I*|-D*) CPPFLAGS="$CPPFLAGS $pgac_option";; | ||
28 | - esac | ||
29 | - done | ||
30 | - for pgac_option in `$XML2_CONFIG --libs`; do | ||
31 | - case $pgac_option in | ||
32 | - -L*) LDFLAGS="$LDFLAGS $pgac_option";; | ||
33 | - esac | ||
34 | - done | ||
35 | - fi | ||
36 | + CPPFLAGS="$CPPFLAGS `pkg-config --short-errors --print-errors --cflags "libxml-2.0" 2>&1`" | ||
37 | + LIBS="`pkg-config --short-errors --print-errors --libs "libxml-2.0" 2>&1` $LIBS" | ||
38 | fi | ||
39 | |||
40 | AC_SUBST(with_libxml) | ||
41 | -- | ||
42 | 1.8.3.1 | ||
43 | |||
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc index 4e5ec026cc..79d12811e8 100644 --- a/meta-oe/recipes-support/postgresql/postgresql.inc +++ b/meta-oe/recipes-support/postgresql/postgresql.inc | |||
@@ -28,6 +28,7 @@ SRC_URI = "http://ftp.postgresql.org/pub/source/v${PV}/${BP}.tar.bz2 \ | |||
28 | file://postgresql.init \ | 28 | file://postgresql.init \ |
29 | file://postgresql-bashprofile \ | 29 | file://postgresql-bashprofile \ |
30 | file://postgresql.pam \ | 30 | file://postgresql.pam \ |
31 | file://0001-Use-pkg-config-for-libxml2-detection.patch \ | ||
31 | " | 32 | " |
32 | 33 | ||
33 | LEAD_SONAME = "libpq.so" | 34 | LEAD_SONAME = "libpq.so" |