diff options
-rw-r--r-- | meta-gnome/recipes-gnome/cheese/cheese/0001-libcheese-Add-GtkWidget-cast-to-avoid-an-incompatibl.patch | 29 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/cheese/cheese_44.1.bb | 26 |
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/cheese/cheese/0001-libcheese-Add-GtkWidget-cast-to-avoid-an-incompatibl.patch b/meta-gnome/recipes-gnome/cheese/cheese/0001-libcheese-Add-GtkWidget-cast-to-avoid-an-incompatibl.patch new file mode 100644 index 0000000000..8d2d413149 --- /dev/null +++ b/meta-gnome/recipes-gnome/cheese/cheese/0001-libcheese-Add-GtkWidget-cast-to-avoid-an-incompatibl.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From d8b8f27730cca948a5e5346b8ed2db0793bb16e7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Florian Weimer <fweimer@redhat.com> | ||
3 | Date: Fri, 19 Jan 2024 21:31:33 +0100 | ||
4 | Subject: [PATCH] libcheese: Add GtkWidget cast to avoid an | ||
5 | incompatible-pointer-types error | ||
6 | |||
7 | This is required for compilation with GCC 14. | ||
8 | |||
9 | Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/cheese/-/merge_requests/70] | ||
10 | --- | ||
11 | libcheese/cheese-flash.c | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/libcheese/cheese-flash.c b/libcheese/cheese-flash.c | ||
15 | index 59959dbd..e4023221 100644 | ||
16 | --- a/libcheese/cheese-flash.c | ||
17 | +++ b/libcheese/cheese-flash.c | ||
18 | @@ -132,7 +132,7 @@ cheese_flash_set_property (GObject *object, | ||
19 | GObject *parent; | ||
20 | parent = g_value_get_object (value); | ||
21 | if (object != NULL) | ||
22 | - priv->parent = g_object_ref (parent); | ||
23 | + priv->parent = GTK_WIDGET (g_object_ref (parent)); | ||
24 | else | ||
25 | priv->parent = NULL; | ||
26 | } | ||
27 | -- | ||
28 | 2.45.2 | ||
29 | |||
diff --git a/meta-gnome/recipes-gnome/cheese/cheese_44.1.bb b/meta-gnome/recipes-gnome/cheese/cheese_44.1.bb new file mode 100644 index 0000000000..180f3f6319 --- /dev/null +++ b/meta-gnome/recipes-gnome/cheese/cheese_44.1.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "Take photos and videos with your webcam, with fun graphical effects" | ||
2 | SECTION = "x11/gnome" | ||
3 | LICENSE = "GPL-2.0-or-later" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf" | ||
5 | |||
6 | inherit gnomebase gobject-introspection vala itstool gtk-icon-cache gsettings gnome-help gtk-doc | ||
7 | |||
8 | SRC_URI += "file://0001-libcheese-Add-GtkWidget-cast-to-avoid-an-incompatibl.patch" | ||
9 | |||
10 | SRC_URI[archive.sha256sum] = "5f2185c4c99e54ddf2b8baf60c82819950e54952e132e8639875f3edcbf8f68e" | ||
11 | |||
12 | DEPENDS += " \ | ||
13 | clutter-1.0 \ | ||
14 | clutter-gst-3.0 \ | ||
15 | clutter-gtk-1.0 \ | ||
16 | gnome-desktop \ | ||
17 | libcanberra \ | ||
18 | libxslt-native \ | ||
19 | " | ||
20 | |||
21 | GTKDOC_MESON_OPTION = "gtk_doc" | ||
22 | |||
23 | # Man page build wants to access sourceforge | ||
24 | EXTRA_OEMESON += "-Dman=false" | ||
25 | |||
26 | FILES:${PN} += "${datadir}" | ||