summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-using-Wno-maybe-uninitialized.patch37
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-using-Wno-maybe-uninitialized.patch b/meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-using-Wno-maybe-uninitialized.patch
new file mode 100644
index 0000000000..2f581855f5
--- /dev/null
+++ b/meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-using-Wno-maybe-uninitialized.patch
@@ -0,0 +1,37 @@
1From 169f62770f63a43b15d4d4c82336fd57c8467cfe Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 4 Apr 2020 21:43:51 -0700
4Subject: [PATCH] cmake: Disable using -Wno-maybe-uninitialized
5
6This warning causes clang builds to fail because this is not a
7recognised warning with clang
8
9Upstream-Status: Pending
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/CMakeLists.txt | 1 -
14 1 file changed, 1 deletion(-)
15
16--- a/src/CMakeLists.txt
17+++ b/src/CMakeLists.txt
18@@ -6,7 +6,6 @@
19 set (SWIG_CXX_DISABLE_WARNINGS -Wno-error
20 -Wno-delete-non-virtual-dtor
21 -Wno-unused-function
22- -Wno-maybe-uninitialized
23 -Wno-strict-aliasing)
24
25 # If building under android, make sure swig gets an ANDROID flag
26--- a/CMakeLists.txt
27+++ b/CMakeLists.txt
28@@ -115,8 +115,7 @@ endif (WERROR)
29 upm_add_compile_flags(C ${C_CXX_WARNING_FLAGS}
30 -Winit-self
31 -Wimplicit
32- -Wsign-compare
33- -Wmissing-parameter-type)
34+ -Wsign-compare)
35
36 # Set CXX compiler warning flags at top-level scope and emit a warning about
37 # unsupported flags
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
index c851c93bc4..3ab6bbb6ba 100644
--- a/meta-oe/recipes-extended/upm/upm_git.bb
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/eclipse/${BPN}.git;protocol=http \
15 file://0001-Use-stdint-types.patch \ 15 file://0001-Use-stdint-types.patch \
16 file://0001-initialize-local-variables-before-use.patch \ 16 file://0001-initialize-local-variables-before-use.patch \
17 file://0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch \ 17 file://0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch \
18 file://0001-cmake-Disable-using-Wno-maybe-uninitialized.patch \
18 " 19 "
19 20
20SRC_URI_append_toolchain-clang_x86 = " file://0001-nmea_gps-Link-with-latomic.patch " 21SRC_URI_append_toolchain-clang_x86 = " file://0001-nmea_gps-Link-with-latomic.patch "