summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch42
-rw-r--r--meta-oe/recipes-dbs/soci/soci_4.0.3.bb (renamed from meta-oe/recipes-dbs/soci/soci_4.0.2.bb)5
2 files changed, 2 insertions, 45 deletions
diff --git a/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch b/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch
deleted file mode 100644
index 8e32ebb0bf..0000000000
--- a/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From fae154eb209e068586e1adb589de5d273fcf4b4f Mon Sep 17 00:00:00 2001
2From: Denis Arnaud <denis.arnaud_fedora@m4x.org>
3Date: Tue, 18 May 2021 00:05:03 +0200
4Subject: [PATCH] Fix build when SIGSTKSZ is no longer a constant
5
6In the latest glibc versions SIGSTKSZ is not a constant any more, which
7broke building the tests with it.
8
9Work around this by hard-coding a typical value for it.
10
11closes #886.
12
13Upstream-Status: Backport.
14---
15 tests/catch.hpp | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/tests/catch.hpp b/tests/catch.hpp
19index 014df2c5..85067813 100644
20--- a/tests/catch.hpp
21+++ b/tests/catch.hpp
22@@ -6489,7 +6489,7 @@ namespace Catch {
23 static bool isSet;
24 static struct sigaction oldSigActions [sizeof(signalDefs)/sizeof(SignalDefs)];
25 static stack_t oldSigStack;
26- static char altStackMem[SIGSTKSZ];
27+ static char altStackMem[8192];
28
29 static void handleSignal( int sig ) {
30 std::string name = "<unknown signal>";
31@@ -6540,7 +6540,7 @@ namespace Catch {
32 bool FatalConditionHandler::isSet = false;
33 struct sigaction FatalConditionHandler::oldSigActions[sizeof(signalDefs)/sizeof(SignalDefs)] = {};
34 stack_t FatalConditionHandler::oldSigStack = {};
35- char FatalConditionHandler::altStackMem[SIGSTKSZ] = {};
36+ char FatalConditionHandler::altStackMem[8192] = {};
37
38 } // namespace Catch
39
40--
412.25.1
42
diff --git a/meta-oe/recipes-dbs/soci/soci_4.0.2.bb b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb
index fb67e0c547..ff47e5033e 100644
--- a/meta-oe/recipes-dbs/soci/soci_4.0.2.bb
+++ b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb
@@ -5,9 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
5SECTION = "libs" 5SECTION = "libs"
6DEPENDS = "boost" 6DEPENDS = "boost"
7 7
8SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \ 8SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz"
9 file://0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch" 9SRC_URI[sha256sum] = "615e5f7e4b52007f3a3b4050a99aadf6346b56b5098eb08b3a650836083c6a33"
10SRC_URI[sha256sum] = "34da2d2320539463da8a5131253246fa2671e0438ab5fd1e5119edb428f558a5"
11 10
12TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \ 11TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \
13 -DSOCI_TEST_POSTGRESQL_CONNSTR:STRING="dbname=soci_test" \ 12 -DSOCI_TEST_POSTGRESQL_CONNSTR:STRING="dbname=soci_test" \